summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorisabel2023-03-27 09:47:50 +0100
committerisabel2023-03-27 09:47:50 +0100
commit2a0fee19f8713b99316c5ba22425a0490d4ccefc (patch)
tree19b816be22a1541c16291de6cc684c59ee99975e
parentc77ff91e31188b67ec48ac150a759701547645d9 (diff)
downloadaur-2a0fee19f8713b99316c5ba22425a0490d4ccefc.tar.gz
fixed make
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4f7bfdac4c9e..c274ff8fd7ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Maintainer: Isabel <isabelroseslive@gmail.com>
pkgname=bellsym-git
+_pkgname=bellsym
pkgver=1.1.0
pkgrel=1
pkgdesc="A simple command line tool to move all config files from a directory to another, and create symbolic links where needed."
@@ -12,16 +13,18 @@ source=("$pkgname::git+$url")
md5sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd "$_pkgname"
printf "1.1.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
+ cd "$_pkgname-$pkgver"
cargo build --release
}
package() {
+ cd "$_pkgname-$pkgver"
install -Dm755 "target/release/bellsym" "$pkgdir/usr/bin/bellsym"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$_pkgname/README.md"
}