summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorisabel2023-03-27 07:54:07 +0100
committerisabel2023-03-27 07:54:07 +0100
commitbc6df5d1ac21ca9bd96a7de12f28533e3ff78613 (patch)
treefc350d3dad257223486acf55d94cede611cd633a
downloadaur-bc6df5d1ac21ca9bd96a7de12f28533e3ff78613.tar.gz
inital commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e88d2528c99
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = bellsym-git
+ pkgdesc = A simple command line tool to move all config files from a directory to another, and create symbolic links where needed.
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/isabelroses/bellsym
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cargo
+ source = git+https://github.com/isabelroses/bellsym
+ md5sums = SKIP
+
+pkgname = bellsym-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3cea9ebd1d2e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Isabel <isabelroseslive@gmail.com>
+pkgname=bellsym-git
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="A simple command line tool to move all config files from a directory to another, and create symbolic links where needed."
+arch=('x86_64')
+url="https://github.com/isabelroses/bellsym"
+license=('MIT')
+depends=()
+makedepends=('git' 'cargo')
+source=("git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "1.1.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 "target/release/bellsym" "$pkgdir/usr/bin/bellsym"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+}