summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-12-17 22:08:08 -0500
committerGuillaume Horel2019-12-17 22:08:08 -0500
commit8786a43536a106a53e07491808d7f70f8398412a (patch)
tree3e33b81772962dac494fd174f4d027cefd16374e
downloadaur-8786a43536a106a53e07491808d7f70f8398412a.tar.gz
initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e34b77639d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = belr
+ pkgdesc = A library for working with vCards
+ pkgver = 4.3.0
+ pkgrel = 1
+ url = http://www.linphone.org/
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = bctoolbox>=4.3
+ source = belr-4.3.0.tar.gz::https://github.com/BelledonneCommunications/belr/archive/4.3.0.tar.gz
+ sha256sums = d801e0f60eb02c9e094c1ad5d69cab82cf42677efac0ea38729b470134683684
+
+pkgname = belr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4cc8864dc02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+
+pkgname=belr
+pkgver=4.3.0
+pkgrel=1
+pkgdesc="A library for working with vCards"
+arch=('x86_64')
+url="http://www.linphone.org/"
+license=('GPL')
+depends=('bctoolbox>=4.3')
+makedepends=('cmake')
+source=("belr-$pkgver.tar.gz::https://github.com/BelledonneCommunications/belr/archive/4.3.0.tar.gz")
+sha256sums=('d801e0f60eb02c9e094c1ad5d69cab82cf42677efac0ea38729b470134683684')
+
+build() {
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_PREFIX_PATH="/usr" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DENABLE_STATIC=NO \
+ -DENABLE_TOOLS=NO \
+ -DCMAKE_SKIP_INSTALL_RPATH=ON "../$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}" install
+}