summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-02-24 19:55:37 +0100
committerMartchus2016-02-24 19:55:37 +0100
commit98b01941f9870fa66be77ba25ef2daedfd0ac9bb (patch)
tree7d0db2f49ef27cd22c483f770a648a48c9f61cc9
downloadaur-98b01941f9870fa66be77ba25ef2daedfd0ac9bb.tar.gz
initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD49
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3abb1875724e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Feb 24 18:55:13 UTC 2016
+pkgbase = bento4
+ pkgdesc = Bento4 is a C++ class library and tools designed to read and write ISO-MP4 files.
+ pkgver = 1.4.3.607
+ pkgrel = 1
+ url = https://www.bento4.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ optdepends = python
+ source = https://github.com/axiomatic-systems/Bento4/archive/v1.4.3-607.tar.gz
+ md5sums = 9c5ebea9e0cef667c214d7df38d00b4e
+
+pkgname = bento4
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eaa963ce5f20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Martchus <youremail@domain.com>
+pkgname=bento4
+pkgver=1.4.3.607
+_pkgverstr=1.4.3-607
+pkgrel=1
+pkgdesc="Bento4 is a C++ class library and tools designed to read and write ISO-MP4 files."
+arch=('i686' 'x86_64')
+url="https://www.bento4.com/"
+license=('GPL')
+makedepends=('cmake')
+optdepends=('python')
+source=("https://github.com/axiomatic-systems/Bento4/archive/v${_pkgverstr}.tar.gz")
+md5sums=('9c5ebea9e0cef667c214d7df38d00b4e')
+_config="Release"
+if [ $CARCH == "i686" ]; then
+ _arch="x86"
+else
+ _arch=$CARCH
+fi
+
+build() {
+ cd "${srcdir}/Bento4-${_pkgverstr}/Build/Targets/$_arch-unknown-linux/"
+ sed -i "6s/.*/AP4_BUILD_CONFIG = $_config/" ../../Makefiles/Bootstrap.mak
+ make sdk AP4_BUILD_CONFIG=$_config
+ # make shared library manually
+ cd "${srcdir}/Bento4-${_pkgverstr}/Build/Targets/$_arch-unknown-linux/$_config/SDK/lib"
+ mkdir shared
+ cd shared
+ ar x ../libAP4.a
+ g++ -shared -Wl,-soname,libAP4.so.$pkgver -o libAP4.so.$pkgver *.o
+}
+
+package() {
+ cd "${srcdir}/Bento4-${_pkgverstr}/Build/Targets/$_arch-unknown-linux/$_config/SDK"
+ mkdir -p "$pkgdir/usr/bin/"
+ mkdir -p "$pkgdir/usr/lib/"
+ mkdir -p "$pkgdir/usr/include/$pkgname/"
+ pushd ./bin
+ for file in *; do
+ # prefix binaries with "bento4-" to avoid conflicts
+ install -m755 -D "./$file" "$pkgdir/usr/bin/bento4-$file"
+ done
+ popd
+ install -m644 -D ./lib/*.a "$pkgdir/usr/lib/" # static lib is usually removed anyways
+ install -m644 -D ./lib/shared/*.so.* "$pkgdir/usr/lib/"
+ install -m644 -D ./include/*.h "$pkgdir/usr/include/$pkgname/"
+ cd "$pkgdir/usr/lib/"
+ ln -s libAP4.so.$pkgver libAP4.so
+}