summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-04-13 23:34:51 +0200
committerMartchus2016-04-13 23:34:51 +0200
commitbb7e8f467109f595ee4c153a4113b97a0ce9fafc (patch)
treef6ee5957598b4a30e9a5c0f2e81459c2463f5b39
parent98b01941f9870fa66be77ba25ef2daedfd0ac9bb (diff)
downloadaur-bb7e8f467109f595ee4c153a4113b97a0ce9fafc.tar.gz
updated to 1.4.3-608
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3abb1875724e..fafeabff561c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Feb 24 18:55:13 UTC 2016
+# Wed Apr 13 21:33:17 UTC 2016
pkgbase = bento4
- pkgdesc = Bento4 is a C++ class library and tools designed to read and write ISO-MP4 files.
- pkgver = 1.4.3.607
+ pkgdesc = C++ class library and tools designed to read and write ISO-MP4 files
+ pkgver = 1.4.3.608
pkgrel = 1
url = https://www.bento4.com/
arch = i686
@@ -10,8 +10,8 @@ pkgbase = bento4
license = GPL
makedepends = cmake
optdepends = python
- source = https://github.com/axiomatic-systems/Bento4/archive/v1.4.3-607.tar.gz
- md5sums = 9c5ebea9e0cef667c214d7df38d00b4e
+ source = https://github.com/axiomatic-systems/Bento4/archive/v1.4.3-608.tar.gz
+ sha256sums = f3e2ae92eb7b1d09e3ae1bfc02a1ab546207bc11033e9e7d6c7a46db53b9a4ca
pkgname = bento4
diff --git a/PKGBUILD b/PKGBUILD
index eaa963ce5f20..721dfd544201 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,22 @@
-# Maintainer: Martchus <youremail@domain.com>
+# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
pkgname=bento4
-pkgver=1.4.3.607
-_pkgverstr=1.4.3-607
+pkgver=1.4.3.608
+_pkgverstr=1.4.3-608
pkgrel=1
-pkgdesc="Bento4 is a C++ class library and tools designed to read and write ISO-MP4 files."
+pkgdesc="C++ class library and tools designed to read and write ISO-MP4 files"
arch=('i686' 'x86_64')
url="https://www.bento4.com/"
license=('GPL')
makedepends=('cmake')
optdepends=('python')
source=("https://github.com/axiomatic-systems/Bento4/archive/v${_pkgverstr}.tar.gz")
-md5sums=('9c5ebea9e0cef667c214d7df38d00b4e')
+sha256sums=('f3e2ae92eb7b1d09e3ae1bfc02a1ab546207bc11033e9e7d6c7a46db53b9a4ca')
_config="Release"
-if [ $CARCH == "i686" ]; then
+if [[ $CARCH == "i686" ]]; then
_arch="x86"
else
_arch=$CARCH
@@ -46,4 +50,4 @@ package() {
install -m644 -D ./include/*.h "$pkgdir/usr/include/$pkgname/"
cd "$pkgdir/usr/lib/"
ln -s libAP4.so.$pkgver libAP4.so
-}
+}