summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Stein2023-01-22 18:18:20 +0100
committerMartchus2023-01-22 18:18:20 +0100
commitdb50a90e09f37318b8b9eedc688d3cc9c097121b (patch)
tree15df4acd8d1d48ba100939147205c39e5b5462f9
parent81fd6f054c0cefcc0c0c9f59d0f155c6286ec3cc (diff)
downloadaur-db50a90e09f37318b8b9eedc688d3cc9c097121b.tar.gz
Support preset CMAKE_GENERATOR
In case this is set to Ninja in user environment, build breaks calling make directly. Instead use the cmake build command which takes the selected generator into account
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD2
2 files changed, 2 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c32ff5567de1..07416ca501b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,3 +16,4 @@ pkgbase = bento4
sha1sums = d3351ffb425aadc698227ba84f5ec3401cad795a
pkgname = bento4
+
diff --git a/PKGBUILD b/PKGBUILD
index edfaea06bff1..96584daa4e14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ build() {
sed -i "s/ STATIC / SHARED /" CMakeLists.txt
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_SKIP_BUILD_RPATH=ON
- make
+ cmake --build .
}
package() {