summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler O'Meara2016-12-17 11:28:48 -0600
committerTyler O'Meara2016-12-17 11:30:07 -0600
commitec511978d2f1223bf939e09c9ced36f01ed3fbe5 (patch)
tree18aeebbe68a1ced3ca52a6f29f9bb13653c38266
downloadaur-ec511978d2f1223bf939e09c9ced36f01ed3fbe5.tar.gz
Initial commit: PKGBUILD for Berach's Complete Pidgin
Signed-off-by: Tyler O'Meara <arch@tyleromeara.com>
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
-rw-r--r--berachs-complete-pidgin-git.install4
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d64210991a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = berachs-complete-pidgin-git
+ pkgdesc = Emote package for the Pidgin IM client
+ pkgver = r141.3c0df5c
+ pkgrel = 1
+ url = https://github.com/Berach/BERACHS_COMPLETE_PIDGIN
+ install = berachs-complete-pidgin-git.install
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = pidgin>=2.0.0
+ provides = berachs-complete-pidgin-git
+ conflicts = berachs-complete-pidgin-git
+ source = git+https://github.com/Berach/BERACHS_COMPLETE_PIDGIN.git
+ md5sums = SKIP
+
+pkgname = berachs-complete-pidgin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8528b88fe769
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Tyler O'Meara <arch at tyleromeara dot com>
+pkgname="berachs-complete-pidgin-git"
+pkgver=r141.3c0df5c
+pkgrel=1
+pkgdesc="Emote package for the Pidgin IM client"
+arch=('any')
+url="https://github.com/Berach/BERACHS_COMPLETE_PIDGIN"
+license=('unknown')
+depends=('pidgin>=2.0.0')
+makedepends=('git')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+install=${pkgname}.install
+source=('git+https://github.com/Berach/BERACHS_COMPLETE_PIDGIN.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/BERACHS_COMPLETE_PIDGIN"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir"
+ mkdir -p "$pkgdir"/usr/share/pixmaps/pidgin/emotes
+ cp -r "BERACHS_COMPLETE_PIDGIN" "$pkgdir"/usr/share/pixmaps/pidgin/emotes
+}
diff --git a/berachs-complete-pidgin-git.install b/berachs-complete-pidgin-git.install
new file mode 100644
index 000000000000..c86b7f4684bf
--- /dev/null
+++ b/berachs-complete-pidgin-git.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo "Note, this package only installs Berach's emote pack for Pidgin, it does not enable it."
+ echo "In order to enable the theme, go to Tools > Preferences > Themes > Smiley Theme in Pidgin and select Berachs Emote Pack 1.8 (SA+REDDIT+OI+EVE)"
+}