summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDustin Childers2021-01-30 23:28:00 -0500
committerDustin Childers2021-01-30 23:28:00 -0500
commite68738242c49bdf69174b42822c6d433eb49b7c6 (patch)
tree961d0e9e46e05846f2abf12ae6e00177a0250e31
downloadaur-e68738242c49bdf69174b42822c6d433eb49b7c6.tar.gz
Initial PKGBUILD for berty 2.251.2
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD19
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d75b43f3223
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = berty-bin
+ pkgdesc = Berty is a secure peer-to-peer messaging app that works with or without internet access, cellular data or trust in the network
+ pkgver = 2.251.2
+ pkgrel = 1
+ url = https://github.com/berty/berty
+ arch = x86_64
+ license = Apache
+ license = MIT
+ depends = libglvnd
+ provides = berty-bin
+ conflicts = berty-bin
+ source = https://github.com/berty/berty/releases/download/v2.251.2/berty_Linux_x86_64.tar.gz
+ sha256sums = d2e19f978035d74b05787d232b52fdbac33358f1405b8d6a107214c3c3d203da
+
+pkgname = berty-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8e9175bdad3c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# Except for these:
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d9c84e15337
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Dustin Childers <dchilders@gmail.com>
+pkgname=berty-bin
+pkgver=2.251.2
+pkgrel=1
+pkgdesc="Berty is a secure peer-to-peer messaging app that works with or without internet access, cellular data or trust in the network"
+arch=('x86_64')
+url="https://github.com/berty/berty"
+license=('Apache' 'MIT')
+depends=('libglvnd')
+provides=('berty-bin')
+conflicts=('berty-bin')
+source=(https://github.com/berty/berty/releases/download/v${pkgver}/berty_Linux_x86_64.tar.gz)
+sha256sums=(d2e19f978035d74b05787d232b52fdbac33358f1405b8d6a107214c3c3d203da)
+
+package() {
+ install -Dm0644 "${srcdir}/berty_Linux_x86_64/LICENSE-APACHE" "${pkgdir}/usr/share/licenses/berty-bin/LICENSE-APACHE"
+ install -Dm0644 "${srcdir}/berty_Linux_x86_64/LICENSE-MIT" "${pkgdir}/usr/share/licenses/berty-bin/LICENSE-MIT"
+ install -Dm0755 "${srcdir}/berty_Linux_x86_64/berty" "${pkgdir}/usr/bin/berty"
+}