summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilk Brewster2020-08-29 23:58:33 +0100
committerMilk Brewster2020-08-29 23:58:33 +0100
commit0801432e28d87343754e628d2fad1516752d6607 (patch)
tree8a43e2e0c649e64943aa86c4156c09f1704a8c8e
parentd42b200cf6e6d3dd5cd41f2076010334908c2f26 (diff)
downloadaur-0801432e28d87343754e628d2fad1516752d6607.tar.gz
fix paths
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82996f2b528a..11298d0b47e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -20,7 +20,7 @@ pkgbase = bespokesynth-git
provides = bespokesynth-bin
conflicts = bespokesynth
conflicts = bespokesynth-bin
- source = bespokesynth::git+https://github.com/awwbees/BespokeSynth
+ source = BespokeSynth::git+https://github.com/awwbees/BespokeSynth
md5sums = SKIP
pkgname = bespokesynth-git
diff --git a/PKGBUILD b/PKGBUILD
index 216a3ecd3dd7..027590276527 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,11 +15,11 @@ provides=('bespokesynth' 'bespokesynth-bin')
conflicts=('bespokesynth' 'bespokesynth-bin')
replaces=()
noextract=()
-source=(${_pkgname}::git+https://github.com/awwbees/BespokeSynth)
+source=(BespokeSynth::git+https://github.com/awwbees/BespokeSynth)
md5sums=('SKIP')
pkgver() {
- cd "$_pkgname"
+ cd "BespokeSynth"
( set -o pipefail
git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
@@ -27,8 +27,7 @@ pkgver() {
}
prepare() {
- pwd
- cd "$_pkgname"
+ cd "BespokeSynth"
sed -i -e 's/usb-1.0/usb-1.0;python3.8/' BespokeSynth.jucer
sed -i -e 's/python-config/python3-config/' BespokeSynth.jucer
sed -i -e 's/JUCE_PLUGINHOST_VST="1"/JUCE_PLUGINHOST_VST="1" JUCE_WEB_BROWSER="0"/' BespokeSynth.jucer
@@ -44,14 +43,14 @@ prepare() {
}
build() {
- cd "$_pkgname"
+ cd "BespokeSynth"
# ./configure --prefix=/usr
cd Builds/LinuxMakefile
CONFIG=Release make
}
package() {
- cd "$_pkgname"
+ cd "BespokeSynth"
mkdir -p ${pkgdir}/usr/bin
install ${srcdir}/BespokeSynth/Builds/LinuxMakefile/build/BespokeSynth ${pkgdir}/usr/bin/BespokeSynth
mkdir -p ${pkgdir}/usr/share/icons/hicolor/512x512/apps