summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilk Brewster2020-08-28 19:21:59 +0100
committerMilk Brewster2020-08-28 19:21:59 +0100
commit33b7d2acce42643b72e0d0df2a35f30174a8fa63 (patch)
treee99b2589eea8a93f1868c2e4b8b0f8330da47ac0
downloadaur-33b7d2acce42643b72e0d0df2a35f30174a8fa63.tar.gz
initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD53
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b1a96aaf4c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = bespokesynth-git
+ pkgdesc = Software modular synth, VST host input, transport/Ableton Push, and Python scripting
+ pkgver = r255.5763dd9
+ pkgrel = 1
+ url = https://github.com/awwbees/BespokeSynth
+ arch = x86_64
+ license = GPL3
+ makedepends = gcc
+ makedepends = libx11
+ makedepends = libxinerama
+ makedepends = freetype2
+ depends = jack
+ depends = curl
+ depends = mesa
+ depends = xorg-xrandr
+ depends = python
+ provides = bespokesynth
+ provides = bespokesynth-bin
+ conflicts = bespokesynth
+ conflicts = bespokesynth-bin
+ source = bespokesynth::git+https://github.com/awwbees/BespokeSynth
+ md5sums = SKIP
+
+pkgname = bespokesynth-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8078a45d3af2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Milkii Brewster <milkii on Freenode IRC>
+maintaner="Milkii Brewster <milkii on Freenode IRC>"
+_pkgname=bespokesynth
+pkgname="$_pkgname"-git
+pkgdesc="Software modular synth, VST host input, transport/Ableton Push, and Python scripting"
+pkgver=r255.5763dd9
+pkgrel=1
+arch=(x86_64)
+url="https://github.com/awwbees/BespokeSynth"
+license=(GPL3)
+depends=('jack' 'curl' 'mesa' 'xorg-xrandr' 'python')
+makedepends=('gcc' 'libx11' 'libxinerama' 'freetype2' )
+checkdepends=()
+optdepends=()
+provides=('bespokesynth' 'bespokesynth-bin')
+conflicts=('bespokesynth' 'bespokesynth-bin')
+replaces=()
+noextract=()
+source=($_pkgname::git+https://github.com/awwbees/BespokeSynth)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "$_pkgname"
+ sed -i -e 's/JUCE_PLUGINHOST_VST="1"/JUCE_PLUGINHOST_VST="1" JUCE_WEB_BROWSER="0"/' BespokeSynth.jucer
+
+ export DISPLAY=":98"
+ Xvfb $DISPLAY >& Xvfb.log &
+ trap "kill $! || true" EXIT
+ sleep 10
+
+ Projucer --set-global-search-path linux defaultJuceModulePath /usr/share/juce/modules
+ Projucer --resave BespokeSynth.jucer
+}
+
+build() {
+ cd "$_pkgname"
+ # ./configure --prefix=/usr
+ cd Builds/LinuxMakefile
+ CONFIG=Release make
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir/" install
+}