summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilk Brewster2020-08-29 20:45:53 +0100
committerMilk Brewster2020-08-29 20:45:53 +0100
commitce1a1e1362228053383b8ef2845f4a579ea2c5d8 (patch)
tree9b111052c725ad2b27821871642297326ede6e6d
parent50e0301ca8f0d4d959a481e9025726d2171cdcfb (diff)
downloadaur-ce1a1e1362228053383b8ef2845f4a579ea2c5d8.tar.gz
build now
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b1a96aaf4c1..eb5c09268b8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bespokesynth-git
pkgdesc = Software modular synth, VST host input, transport/Ableton Push, and Python scripting
- pkgver = r255.5763dd9
+ pkgver = r259.042693b
pkgrel = 1
url = https://github.com/awwbees/BespokeSynth
arch = x86_64
@@ -14,6 +14,8 @@ pkgbase = bespokesynth-git
depends = mesa
depends = xorg-xrandr
depends = python
+ depends = libxext
+ depends = ladspa
provides = bespokesynth
provides = bespokesynth-bin
conflicts = bespokesynth
diff --git a/PKGBUILD b/PKGBUILD
index 8078a45d3af2..f0a2dece517d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,13 @@
# Maintainer: Milkii Brewster <milkii on Freenode IRC>
-maintaner="Milkii Brewster <milkii on Freenode IRC>"
_pkgname=bespokesynth
pkgname="$_pkgname"-git
pkgdesc="Software modular synth, VST host input, transport/Ableton Push, and Python scripting"
-pkgver=r255.5763dd9
+pkgver=r259.042693b
pkgrel=1
arch=(x86_64)
url="https://github.com/awwbees/BespokeSynth"
license=(GPL3)
-depends=('jack' 'curl' 'mesa' 'xorg-xrandr' 'python')
+depends=('jack' 'curl' 'mesa' 'xorg-xrandr' 'python' 'libxext' 'ladspa')
makedepends=('gcc' 'libx11' 'libxinerama' 'freetype2' )
checkdepends=()
optdepends=()
@@ -29,8 +28,11 @@ pkgver() {
prepare() {
cd "$_pkgname"
+ sed -i -e 's/usb-1.0/usb-1.0;python3.8/' BespokeSynth.jucer
+ sed -i -e 's/python-config/python3-config/' BespokeSynth.jucer
sed -i -e 's/JUCE_PLUGINHOST_VST="1"/JUCE_PLUGINHOST_VST="1" JUCE_WEB_BROWSER="0"/' BespokeSynth.jucer
+ ### Launch a virtual framebuffer X server ###
export DISPLAY=":98"
Xvfb $DISPLAY >& Xvfb.log &
trap "kill $! || true" EXIT
@@ -49,5 +51,10 @@ build() {
package() {
cd "$_pkgname"
- make DESTDIR="$pkgdir/" install
+ mkdir -p ${pkgdir}/usr/share/BespokeSynth
+ install ${srcdir}/Builds/LinuxMakefile/build/BespokeSynth ${pkgdir}/usr/share/BespokeSynth
+ mkdir -p ${pkgdir}/usr/share/icons/hicolor/512x512/apps
+ install ${srcdir}/Builds/LinuxMakefile/build/BespokeSynth/bespoke_icon.png ${pkgdir}/usr/share/icons/hicolor/512x512/apps
+
+
}