summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake2022-01-11 23:34:11 +0100
committerJake2022-01-11 23:34:44 +0100
commitee9002da7b10e9a1f8dee5fe61e1771bac10944d (patch)
tree1580760b82d1d07a59bd4c7aea2f22e5a18bd6eb
parent6f11a254b5fbd6581e4bd051b8af334558e1c419 (diff)
downloadaur-ee9002da7b10e9a1f8dee5fe61e1771bac10944d.tar.gz
betaflight-configurator: Patch out android dependency
fixes build error on node v17.x
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--remove_android_build_deps.patch25
3 files changed, 36 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38fd2aa5fb44..83e60a3a3ade 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = betaflight-configurator
pkgdesc = Crossplatform configuration tool for the Betaflight flight control system
pkgver = 10.7.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/betaflight/betaflight-configurator
install = betaflight-configurator.install
arch = x86_64
@@ -14,8 +14,10 @@ pkgbase = betaflight-configurator
source = git+https://github.com/betaflight/betaflight-configurator.git#tag=10.7.2
source = betaflight-configurator.sh
source = betaflight-configurator.desktop
+ source = remove_android_build_deps.patch
sha512sums = SKIP
sha512sums = 1f9113fce812355d1f8cc614d4905845c601622b87aad2b6e74b62913582018a87059727a333db0673a4b767a10564389eece1f588658d171dc4d8446055a0e9
sha512sums = 79e5ab59cf8520ce7e20fb2bd89ee99ce3debba69e7da892bf219912cc32c7056a7c8fd6dae19eebfe4956c948d0bc75ece40911b203fcc2f34e43f2d8329532
+ sha512sums = baa70c87a0fa85251ffd3d2fdf09e108e460283ef8132947cd75a33232217b2ff3fb84672d8138df8ad5be058b45309f020515c7750e81b4689756dca35660b2
pkgname = betaflight-configurator
diff --git a/PKGBUILD b/PKGBUILD
index 8625374af22f..3e3a301286b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=betaflight-configurator
pkgver=10.7.2
-pkgrel=1
+pkgrel=2
pkgdesc="Crossplatform configuration tool for the Betaflight flight control system"
arch=('x86_64')
url="https://github.com/betaflight/betaflight-configurator"
@@ -12,10 +12,12 @@ depends=('nwjs-bin')
makedepends=('yarn' 'npm' 'git')
source=("git+https://github.com/betaflight/betaflight-configurator.git#tag=$pkgver"
"$pkgname.sh"
- "$pkgname.desktop")
+ "$pkgname.desktop"
+ "remove_android_build_deps.patch")
sha512sums=('SKIP'
'1f9113fce812355d1f8cc614d4905845c601622b87aad2b6e74b62913582018a87059727a333db0673a4b767a10564389eece1f588658d171dc4d8446055a0e9'
- '79e5ab59cf8520ce7e20fb2bd89ee99ce3debba69e7da892bf219912cc32c7056a7c8fd6dae19eebfe4956c948d0bc75ece40911b203fcc2f34e43f2d8329532')
+ '79e5ab59cf8520ce7e20fb2bd89ee99ce3debba69e7da892bf219912cc32c7056a7c8fd6dae19eebfe4956c948d0bc75ece40911b203fcc2f34e43f2d8329532'
+ 'baa70c87a0fa85251ffd3d2fdf09e108e460283ef8132947cd75a33232217b2ff3fb84672d8138df8ad5be058b45309f020515c7750e81b4689756dca35660b2')
options=(!strip)
install=$pkgname.install
@@ -24,6 +26,9 @@ prepare() {
# Allow higher node version
sed 's#"node": "#&>=#' -i package.json
+
+ # Remove unecessary Andoid/Cordova XML build dependcy
+ patch -Np1 < "$srcdir/remove_android_build_deps.patch"
}
build() {
diff --git a/remove_android_build_deps.patch b/remove_android_build_deps.patch
new file mode 100644
index 000000000000..22f7bcb139a3
--- /dev/null
+++ b/remove_android_build_deps.patch
@@ -0,0 +1,25 @@
+diff --git a/gulpfile.js b/gulpfile.js
+index a9183e96..431a3a8b 100644
+--- a/gulpfile.js
++++ b/gulpfile.js
+@@ -25,7 +25,7 @@ const yarn = require("gulp-yarn");
+ const rename = require('gulp-rename');
+ const replace = require('gulp-replace');
+ const jeditor = require("gulp-json-editor");
+-const xmlTransformer = require("gulp-xml-transformer");
++const xmlTransformer = null
+ const os = require('os');
+ const git = require('gulp-git');
+ const source = require('vinyl-source-stream');
+diff --git a/package.json b/package.json
+index 2cb5b9e5..15700e8f 100644
+--- a/package.json
++++ b/package.json
+@@ -76,7 +76,6 @@
+ "gulp-json-editor": "^2.5.4",
+ "gulp-rename": "^2.0.0",
+ "gulp-replace": "^1.0.0",
+- "gulp-xml-transformer": "^3.0.0",
+ "gulp-yarn": "^2.0.0",
+ "gulp-zip": "^5.0.0",
+ "karma": "^4.0.1",