summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJordan Day2023-02-28 07:16:52 -0600
committerJordan Day2023-02-28 07:16:52 -0600
commitbd0cf8c3a9a59ab6eda698a57036ed720dcde90d (patch)
tree3a460186ec1d9c707bbe976dccc3ca9a1a606112
parentdd2cd091ff87b891301a0b977f87d6b7a2759180 (diff)
downloadaur-bd0cf8c3a9a59ab6eda698a57036ed720dcde90d.tar.gz
Permission fixes
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ddf34712090f..769500e15b81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = betaflight-configurator-bin
pkgdesc = Crossplatform configuration tool for the Betaflight flight control system
pkgver = 10.9.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/betaflight/betaflight-configurator
install = betaflight-configurator-bin.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 9da0356f0062..45f4a84db614 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=betaflight-configurator-bin
_pkgname=betaflight-configurator
pkgver=10.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="Crossplatform configuration tool for the Betaflight flight control system"
arch=('x86_64')
url="https://github.com/betaflight/betaflight-configurator"
@@ -20,5 +20,9 @@ package() {
install -Dm644 "$srcdir/Betaflight Configurator/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
cp -dpr --no-preserve=ownership "$srcdir/Betaflight Configurator" "$pkgdir/opt/betaflight/betaflight-configurator"
ln -s "/opt/betaflight/betaflight-configurator/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ # Perm fixes https://github.com/betaflight/betaflight-configurator/issues/3009#issuecomment-1260777532
+ chmod +xr /opt/betaflight/betaflight-configurator/chrome_crashpad_handler
+ chmod +xr /opt/betaflight/betaflight-configurator/betaflight-configurator
+ chmod -R +Xr /opt/betaflight/betaflight-configurator/
}