summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Debucquoy2024-01-26 16:41:06 +0100
committerAnthony Debucquoy2024-01-26 16:41:06 +0100
commit2c71dbc8042bb1b134416a062b6c939f2bd049ae (patch)
treee160f43c818decd9d20dd037f24a222569c0d6f7
parent15024cd52d63cff9200306f631f6c55b2460d377 (diff)
downloadaur-2c71dbc8042bb1b134416a062b6c939f2bd049ae.tar.gz
Update script + Update version 1.11.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD4
-rwxr-xr-xupdate.sh8
3 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 99a91d9bcfef..b563203719b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = better-commits
pkgdesc = A CLI for creating better commits following the conventional commit guidelines.
- pkgver = 1.10.0
+ pkgver = 1.11.0
pkgrel = 1
url = https://github.com/Everduin94/better-commits
arch = any
license = MIT
makedepends = npm
- noextract = better-commits-1.10.0.tgz
- source = https://registry.npmjs.org/better-commits/-/better-commits-1.10.0.tgz
- sha256sums = e8efe80e0064f706ddd65e323208d15924751ee05fd61078ad7e4e4caf94c708
+ noextract = better-commits-1.11.0.tgz
+ source = https://registry.npmjs.org/better-commits/-/better-commits-1.11.0.tgz
+ sha256sums = 7b955b87446f1410ca15e958b932b5ac2b324b441012dd355070d9bc7f58dd8a
pkgname = better-commits
diff --git a/PKGBUILD b/PKGBUILD
index 9adfb2c50452..2c56c01e2d5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Debucquoy Anthony (tonitch) <d.tonitch@gmail.com>
pkgname=better-commits
-pkgver=1.10.0
+pkgver=1.11.0
pkgrel=1
pkgdesc="A CLI for creating better commits following the conventional commit guidelines."
arch=(any)
@@ -9,7 +9,7 @@ license=('MIT')
makedepends=('npm')
source=("https://registry.npmjs.org/${pkgname}/-/${pkgname}-${pkgver}.tgz")
noextract=("${pkgname}-${pkgver}.tgz")
-sha256sums=('e8efe80e0064f706ddd65e323208d15924751ee05fd61078ad7e4e4caf94c708')
+sha256sums=('7b955b87446f1410ca15e958b932b5ac2b324b441012dd355070d9bc7f58dd8a')
package() {
npm install -g --cache "${srcdir}/npm-cache" --prefix "${pkgdir}/usr" "${srcdir}/${pkgname}-${pkgver}.tgz"
diff --git a/update.sh b/update.sh
new file mode 100755
index 000000000000..0963ef4c8960
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,8 @@
+#!/bin/bash
+
+lastVer=$(curl "https://registry.npmjs.com/better-commits" | jq -r '."dist-tags"."latest"' )
+sed -i "/pkgver/s/[0-9]\+\.[0-9]\+\.[0-9]\+/${lastVer}/" ./PKGBUILD
+sum=$(makepkg -g)
+sed -i "s/sha256sums=.*\$/${sum}/" ./PKGBUILD
+makepkg --printsrcinfo > .SRCINFO
+git commit -a