summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDebucquoy Anthony (tonitch)2024-01-08 14:02:47 +0100
committerDebucquoy Anthony (tonitch)2024-01-08 14:03:02 +0100
commitd1b9cb0a13fc02387de58725f38d1886d7edded5 (patch)
treeb06f4618973a13776316a3fee9581c9cb86c0cb8
downloadaur-d1b9cb0a13fc02387de58725f38d1886d7edded5.tar.gz
Adding better-commit to aur
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD16
2 files changed, 29 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21e6f2a39110
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = better-commits
+ pkgdesc = A CLI for creating better commits following the conventional commit guidelines.
+ pkgver = 1.7.2
+ pkgrel = 1
+ url = https://github.com/Everduin94/better-commits
+ arch = any
+ license = MIT
+ makedepends = npm
+ noextract = better-commits-1.7.2.tgz
+ source = https://registry.npmjs.org/better-commits/-/better-commits-1.7.2.tgz
+ sha256sums = 80721b65c4912dd96c1140f8d6932ca86725f3d9a1d286f912cffa119739ad87
+
+pkgname = better-commits
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c57621fa791
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Debucquoy Anthony (tonitch) <d.tonitch@gmail.com>
+pkgname=better-commits
+pkgver=1.7.2
+pkgrel=1
+pkgdesc="A CLI for creating better commits following the conventional commit guidelines."
+arch=(any)
+url="https://github.com/Everduin94/better-commits"
+license=('MIT')
+makedepends=('npm')
+source=("https://registry.npmjs.org/${pkgname}/-/${pkgname}-${pkgver}.tgz")
+noextract=("${pkgname}-${pkgver}.tgz")
+sha256sums=('80721b65c4912dd96c1140f8d6932ca86725f3d9a1d286f912cffa119739ad87')
+
+package() {
+ npm install -g --cache "${srcdir}/npm-cache" --prefix "${pkgdir}/usr" "${srcdir}/${pkgname}-${pkgver}.tgz"
+}