summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-03 12:43:19 +0800
committerzxp198210052023-11-03 12:43:19 +0800
commit8000749b0725cf0e961fbf51a2fee646428c0ed3 (patch)
tree712f682f4432d5a2444984386372f6d2ea49d208
downloadaur-8000749b0725cf0e961fbf51a2fee646428c0ed3.tar.gz
update to 1.0.6
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD44
-rw-r--r--better-osu-skills.sh11
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2081e43ed80
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = better-osu-skills-bin
+ pkgdesc = Gets results from the osu!Skills training page and PMs them on osu! using your own IRC credentials
+ pkgver = 1.0.6
+ pkgrel = 1
+ url = https://github.com/straightcurve/better-osuskills
+ arch = x86_64
+ license = custom
+ makedepends = squashfuse
+ depends = bash
+ depends = electron11
+ depends = hicolor-icon-theme
+ depends = libxext
+ depends = gdk-pixbuf2
+ depends = libdbusmenu-glib
+ depends = gtk2
+ conflicts = better-osu-skills
+ source = better-osu-skills-1.0.6.AppImage::https://github.com/straightcurve/better-osuskills/releases/download/v1.0.6/better-osu-skills-1.0.6.AppImage
+ source = better-osu-skills.sh
+ sha256sums = 8fe449e2e93f061a3446aa2fd346eaeb0982b83529ed381834b059c7bb1f7d28
+ sha256sums = 1a97bc17f7f5c0f9666c0e2cf85fd306447407c2e28fd01d8c0dc0f4ddafc204
+
+pkgname = better-osu-skills-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5abeda1df60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=better-osu-skills-bin
+pkgver=1.0.6
+pkgrel=1
+pkgdesc="Gets results from the osu!Skills training page and PMs them on osu! using your own IRC credentials"
+arch=('x86_64')
+url="https://github.com/straightcurve/better-osuskills"
+license=('custom')
+conflicts=("${pkgname%-bin}")
+depends=(
+ 'bash'
+ 'electron11'
+ 'hicolor-icon-theme'
+ 'libxext'
+ 'gdk-pixbuf2'
+ 'libdbusmenu-glib'
+ 'gtk2'
+)
+makedepends=(
+ 'squashfuse'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}.AppImage"
+ "${pkgname%-bin}.sh"
+)
+sha256sums=('8fe449e2e93f061a3446aa2fd346eaeb0982b83529ed381834b059c7bb1f7d28'
+ '1a97bc17f7f5c0f9666c0e2cf85fd306447407c2e28fd01d8c0dc0f4ddafc204')
+build() {
+ chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
+ "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
+ sed "s|AppRun %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/swiftshader/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/swiftshader"
+ install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/lib"
+ for _icons in 16x16 32x32 48x48 64x64 128x128 256x256;do
+ install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
+ -t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps/"
+ done
+ install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/squashfs-root/LICENSE"* -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file
diff --git a/better-osu-skills.sh b/better-osu-skills.sh
new file mode 100644
index 000000000000..c57bdfe0de96
--- /dev/null
+++ b/better-osu-skills.sh
@@ -0,0 +1,11 @@
+#!/bin/bash
+_ELECTRON=/usr/bin/electron11
+APPDIR="/usr/lib/better-osu-skills"
+export PATH="${APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${APPDIR}/lib:${APPDIR}/swiftshader:${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/app.asar"
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec ${_ELECTRON} ${_ASAR} "$@"
+else
+ exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+fi \ No newline at end of file