summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Neumann2018-10-21 13:12:24 +0200
committerJan Neumann2018-10-21 13:12:24 +0200
commit53b3c7ece6a1e83bef05442bcbb17636cb7c0c03 (patch)
tree58036c0d9cd1a9509342722a7d96af5e64ecdffe
downloadaur-53b3c7ece6a1e83bef05442bcbb17636cb7c0c03.tar.gz
initial upload
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..117d56bec53c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = better-plasma5-video-wallpaper-git
+ pkgdesc = Plasma 5 plugin for video-wallpaper without gaps during loops
+ pkgver = r4.40ba42f
+ pkgrel = 1
+ url = https://github.com/WuSiYu/PlasmaVideoWallpaper
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = extra-cmake-modules
+ depends = plasma-desktop
+ source = git+https://github.com/WuSiYu/PlasmaVideoWallpaper.git
+ sha256sums = SKIP
+
+pkgname = better-plasma5-video-wallpaper-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..979878b428cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+
+# Maintainer: Jan Neumann <neum dot ja at gmail dot com>
+
+
+pkgname=better-plasma5-video-wallpaper-git
+_gitname=PlasmaVideoWallpaper
+pkgver=r4.40ba42f
+pkgrel=1
+pkgdesc='Plasma 5 plugin for video-wallpaper without gaps during loops'
+arch=('any')
+url='https://github.com/WuSiYu/PlasmaVideoWallpaper'
+license=('GPL3')
+depends=('plasma-desktop')
+makedepends=('git' 'cmake' 'extra-cmake-modules')
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/${_gitname}
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
+
+build() {
+ cd ${srcdir}/${_gitname}
+ mkdir build && cd build
+ cmake ..
+
+ make
+
+}
+
+package() {
+ cd ${srcdir}/${_gitname}
+ make -C ${srcdir}/${_gitname}/build DESTDIR="$pkgdir" install
+
+}