summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2016-03-04 15:26:20 +0100
committeranthraxx2016-03-04 15:26:20 +0100
commitd14ed9844cea3861efa87d28d611ca7d77314bc6 (patch)
tree805904eefe276c6fffee40551698f29712bbbc23
downloadaur-d14ed9844cea3861efa87d28d611ca7d77314bc6.tar.gz
addpkg: bettercap-git 1.4.5.684.322501b-1
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD37
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78d468c839ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Fri Mar 4 14:26:20 UTC 2016
+pkgbase = bettercap-git
+ pkgdesc = Complete, modular, portable and easily extensible MITM framework
+ pkgver = 1.4.5.684.322501b
+ pkgrel = 1
+ url = https://github.com/evilsocket/bettercap
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = ruby
+ depends = ruby-network_interface
+ depends = ruby-pcaprub
+ depends = ruby-packetfu
+ depends = ruby-colorize
+ depends = ruby-net-dns
+ provides = bettercap
+ conflicts = bettercap
+ options = !emptydirs
+ source = bettercap-git::git+https://github.com/evilsocket/bettercap
+ sha512sums = SKIP
+
+pkgname = bettercap-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..340b09c6d3d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+
+pkgname=bettercap-git
+pkgver=1.4.5.684.322501b
+pkgrel=1
+pkgdesc='Complete, modular, portable and easily extensible MITM framework'
+url='https://github.com/evilsocket/bettercap'
+arch=('any')
+license=('GPL3')
+depends=('ruby' 'ruby-network_interface' 'ruby-pcaprub' 'ruby-packetfu' 'ruby-colorize' 'ruby-net-dns') # 'ruby-rubydns'
+makedepends=('git')
+provides=('bettercap')
+conflicts=('bettercap')
+options=('!emptydirs')
+source=(${pkgname}::git+https://github.com/evilsocket/bettercap)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ printf "%s.%s.%s" "$(git describe --tags --abbrev=0|cut -dv -f2)" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${pkgname}
+ gem build bettercap.gemspec
+}
+
+package() {
+ cd ${pkgname}
+ local _gemdir="$(ruby -e'puts Gem.default_dir')"
+ gem install --ignore-dependencies --no-user-install -i "${pkgdir}/${_gemdir}" -n "${pkgdir}/usr/bin" bettercap*.gem
+ install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: