summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzoorat2023-11-12 00:12:52 +0600
committerzoorat2023-11-12 00:12:52 +0600
commit8763e136e8fa4292486262bf230cfbcc5f79949a (patch)
treeee47c2c403d279e3e5bf2201c9cb745a9397fc0c
parentf7ef90687acf363774d7bedaf5907ff4750f9ab6 (diff)
downloadaur-8763e136e8fa4292486262bf230cfbcc5f79949a.tar.gz
adding better tooling
-rw-r--r--.SRCINFO32
-rw-r--r--.gitignore6
-rw-r--r--Makefile90
-rw-r--r--PKGBUILD38
-rw-r--r--changelog.md11
5 files changed, 163 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c4842cd217b..18cb4eed1b7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,37 @@
pkgbase = betterdiscord-installer-bin
pkgdesc = A simple standalone program which automates the installation, removal and maintenance of BetterDiscord.
pkgver = 1.3.0
- pkgrel = 1
- url = https://github.com/BetterDiscord/Installer
+ pkgrel = 2
+ url = https://betterdiscord.app/
arch = x86_64
license = MIT
- depends = nss
+ depends = alsa-lib
+ depends = at-spi2-core
+ depends = sh
+ depends = cairo
+ depends = dbus
+ depends = expat
+ depends = gcc-libs
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
depends = gtk3
- depends = libxss
+ depends = hicolor-icon-theme
+ depends = libcups
+ depends = libdrm
+ depends = libx11
+ depends = libxcb
+ depends = libxcomposite
+ depends = libxdamage
+ depends = libxext
+ depends = libxfixes
+ depends = libxkbcommon
+ depends = libxrandr
+ depends = libxshmfence
+ depends = mesa
+ depends = nspr
+ depends = nss
+ depends = pango
provides = betterdiscord
provides = betterdiscord-installer
conflicts = betterdiscord
diff --git a/.gitignore b/.gitignore
index 93a647ea7aec..fd1cf73e6413 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,6 @@
*
!.gitignore
-!.SRCINFO
+!Makefile
!PKGBUILD
-!usr--SLASH--bin--SLASH--betterdiscord-installer
-
+!.SRCINFO
+!changelog.md
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..9f11a200e2a1
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,90 @@
+MAKEFLAGS += --warn-undefined-variables
+SHELL=/bin/bash
+
+REPO = "https://github.com/BetterDiscord/Installer"
+VERSION = $(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | tr -d '[:space:]')
+TRASH = $(shell git check-ignore * | tr '\n' ' ')
+
+# DEFAULT
+all: clean log sum build check pre clean
+
+# just build the package
+build:
+ makepkg -sfr
+
+# build and install the package
+install:
+ makepkg --install
+
+# update checksums
+sum:
+ updpkgsums
+
+# check/lint
+check:
+ @echo "shellcheck: "
+ shellcheck -e SC2148 -e SC2034 PKGBUILD || exit 0
+
+ @echo "shell formate: "
+ shfmt -d PKGBUILD || exit 0
+
+ @echo "checking PKGBUILD: "
+ namcap -i PKGBUILD
+
+ @echo "checking build: "
+ namcap -i *.pkg.*
+
+# clean up the mess
+clean:
+ifeq ($(strip $(TRASH)),)
+ @echo "nothing to clear"
+else
+ file $(TRASH)
+ @echo -n "Are you sure? [Y/n] " && read ans && if [ $${ans:-'Y'} = 'Y' ]; then \
+ trash-put -v $(TRASH) ; \
+ exit 0 ; \
+ fi
+endif
+
+# generate `changelog.md`
+log:
+ @echo "wait, it will take some time"
+ $(eval NAME := $(shell gh release --repo $(REPO) view --json name | jq -r .name))
+ echo "# Name: $(NAME) " >changelog.md
+ $(eval URL := $(shell gh release --repo $(REPO) view --json url | jq -r .url))
+ echo "### URL: $(URL)" >>changelog.md
+ $(eval PUBLISHED_AT := $(shell gh release --repo $(REPO) view --json publishedAt | jq -r .publishedAt))
+ $(eval AUTHOR := $(shell gh release --repo $(REPO) view --json author | jq -r .author.login))
+ echo "### published at '$(PUBLISHED_AT)' by $(AUTHOR)" >>changelog.md
+ echo "---" >>changelog.md
+ gh release --repo $(REPO) view --json body | jq -r .body >>changelog.md
+
+# prepare for commit
+pre:
+ shfmt -w PKGBUILD
+ makepkg --printsrcinfo > .SRCINFO
+
+ git diff
+
+ git add PKGBUILD
+ git add changelog.md
+ git add .SRCINFO
+ git add .gitignore
+ git add Makefile
+
+# commit with version bump message
+commit:
+ $(eval VERSION := $(shell read -p "enter version (pkgver=$(VERSION)): " enter ; echo $${enter}))
+ @echo "commit message: \"updating to v$(VERSION)\""
+
+ @echo -n "Are you sure? [Y/n] " && read ans && if [ $${ans:-'Y'} = 'Y' ]; then \
+ git diff --cached ; \
+ exit 0 ; \
+ fi
+
+ @echo -n "Are you sure? [Y/n] " && read ans && if [ $${ans:-'Y'} = 'Y' ]; then \
+ git commit -m "updating to v$(VERSION)" ; \
+ exit 0 ; \
+ fi
+
+ @echo "recheck everything before pushing to AUR"
diff --git a/PKGBUILD b/PKGBUILD
index 4f2eb36f1ff4..32d5324a2414 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,45 @@
_pkgname="betterdiscord-installer"
pkgname="$_pkgname-bin"
pkgver=1.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="A simple standalone program which automates the installation, removal and maintenance of BetterDiscord."
arch=('x86_64')
-url="https://github.com/BetterDiscord/Installer"
-# url="https://betterdiscord.app/"
+# url="https://github.com/BetterDiscord/Installer"
+url="https://betterdiscord.app/"
license=('MIT')
-depends=("nss" "gtk3" "libxss")
+depends=("alsa-lib"
+ "at-spi2-core"
+ "sh"
+ "cairo"
+ "dbus"
+ "expat"
+ "gcc-libs"
+ "gdk-pixbuf2"
+ "glib2"
+ "glibc"
+ "gtk3"
+ "hicolor-icon-theme"
+ "libcups"
+ "libdrm"
+ "libx11"
+ "libxcb"
+ "libxcomposite"
+ "libxdamage"
+ "libxext"
+ "libxfixes"
+ "libxkbcommon"
+ "libxrandr"
+ "libxshmfence"
+ "mesa"
+ "nspr"
+ "nss"
+ "pango")
provides=("betterdiscord" "$_pkgname")
conflicts=("betterdiscord" "$_pkgname")
replaces=("betterdiscord" "$_pkgname")
-# options=(debug !strip emptydirs zipman)
options=(strip emptydirs zipman)
-# install="$pkgname.install"
source=("${pkgname}-${pkgver}.${CARCH}.AppImage::https://github.com/BetterDiscord/Installer/releases/download/v${pkgver}/BetterDiscord-Linux.AppImage"
"LICENSE::https://raw.githubusercontent.com/BetterDiscord/Installer/main/LICENSE"
@@ -32,7 +56,7 @@ prepare() {
chmod +x "${pkgname}-${pkgver}.${CARCH}.AppImage"
# extract .AppImage file
- "./${pkgname}-${pkgver}.${CARCH}.AppImage" --appimage-extract
+ "./${pkgname}-${pkgver}.${CARCH}.AppImage" --appimage-extract >/dev/null
}
build() {
diff --git a/changelog.md b/changelog.md
new file mode 100644
index 000000000000..23cb84a7288d
--- /dev/null
+++ b/changelog.md
@@ -0,0 +1,11 @@
+# Name: v1.3.0
+### URL: https://github.com/BetterDiscord/Installer/releases/tag/v1.3.0
+### published at '2023-05-15T01:00:37Z' by BetterDiscordServices
+---
+## What's Changed
+* Fix webpack builds for modern node versions by @rauenzi in https://github.com/BetterDiscord/Installer/pull/333
+* Implement download from site by @Inve1951 in https://github.com/BetterDiscord/Installer/pull/347
+
+**Full Changelog**: https://github.com/BetterDiscord/Installer/compare/v1.2.1...v1.3.0
+
+Update: Windows build now includes code signing.