summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheCynicalLiger2021-01-18 22:17:01 +0000
committerTheCynicalLiger2021-01-18 22:17:01 +0000
commitf502cdaba2c7ee36ba115d6e652ace90b91e2f42 (patch)
tree828fa29a9d94d59f2997a49a6fdae4d7c2386950
downloadaur-f502cdaba2c7ee36ba115d6e652ace90b91e2f42.tar.gz
First Build
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD33
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11bea7029308
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = bfetch
+ pkgdesc = A CLI system information tool written in BASH that supports displaying images.
+ pkgver = 2021.01.18
+ pkgrel = 1
+ url = https://github.com/TheCynicalTeam/bfetch
+ arch = any
+ license = CC BY-NC-SA 4.0
+ makedepends = git
+ depends = bash
+ optdepends = catimg: Display Images
+ optdepends = chafa: Image to text support
+ optdepends = feh: Wallpaper Display
+ optdepends = imagemagick: Image cropping / Thumbnail creation / Take a screenshot
+ optdepends = jp2a: Display Images
+ optdepends = libcaca: Display Images
+ optdepends = nitrogen: Wallpaper Display
+ optdepends = w3m: Display Images
+ optdepends = xorg-xdpyinfo: Resolution detection (Single Monitor)
+ optdepends = xorg-xprop: Desktop Environment and Window Manager
+ optdepends = xorg-xrandr: Resolution detection (Multi Monitor + Refresh rates)
+ source = bfetch-2021.01.18.tar.gz::https://github.com/TheCynicalTeam/bfetch/archive/2021.01.18.tar.gz
+ sha256sums = 0f247c19fe038322e2905a7bbfa1e28ced37bbbbc6a7776a19a6c74333352ac4
+
+pkgname = bfetch
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..07b96b49345c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+src/*
+pkg/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8fd86728286f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: TheCynicalTeam <TheCynicalTeam@github.com>
+# Contributor: TheCynicalTeam <TheCynicalTeam@github.com>
+
+pkgname=bfetch
+pkgver=2021.01.18
+pkgrel=1
+pkgdesc="A CLI system information tool written in BASH that supports displaying images."
+arch=('any')
+url="https://github.com/TheCynicalTeam/$pkgname"
+license=('CC BY-NC-SA 4.0')
+depends=('bash')
+makedepends=('git')
+optdepends=(
+ 'catimg: Display Images'
+ 'chafa: Image to text support'
+ 'feh: Wallpaper Display'
+ 'imagemagick: Image cropping / Thumbnail creation / Take a screenshot'
+ 'jp2a: Display Images'
+ 'libcaca: Display Images'
+ 'nitrogen: Wallpaper Display'
+ 'w3m: Display Images'
+ 'xorg-xdpyinfo: Resolution detection (Single Monitor)'
+ 'xorg-xprop: Desktop Environment and Window Manager'
+ 'xorg-xrandr: Resolution detection (Multi Monitor + Refresh rates)'
+)
+source=("${pkgname}-$pkgver.tar.gz::${url}/archive/$pkgver.tar.gz")
+sha256sums=('0f247c19fe038322e2905a7bbfa1e28ced37bbbbc6a7776a19a6c74333352ac4')
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+}