summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordpellegr2021-09-07 16:58:39 +0200
committerdpellegr2021-09-07 16:58:39 +0200
commiteaf62e4c548bd3ff8f807d0d4c63ae902ddd9735 (patch)
treefc367704e8d49734dd8613ba7e5513ea08027657
parent826a9a8e199b32af2137b4d3430c26d9866bcaa3 (diff)
downloadaur-eaf62e4c548bd3ff8f807d0d4c63ae902ddd9735.tar.gz
Removed the no-politics patch
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
-rw-r--r--clean.patch25
3 files changed, 4 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2c9b3ed6c68..a32abb06d171 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = bfg-git
- pkgdesc = Removes large blobs like git-filter-branch does, but faster. Git version, no politics.
+ pkgdesc = Removes large blobs like git-filter-branch does, but faster.
pkgver = r465.aeee9e3
pkgrel = 1
url = https://github.com/rtyley/bfg-repo-cleaner
@@ -10,10 +10,7 @@ pkgbase = bfg-git
depends = bash
source = git+https://github.com/rtyley/bfg-repo-cleaner.git
source = bfg.sh
- source = clean.patch
sha256sums = SKIP
sha256sums = a41ad8ff48364c1118e69f5c1c6c5c070d56ad1d2f9cd09bca3c095385a6b530
- sha256sums = 99088f640a8ae89521eb5c5bfbdd96be348b1ccd6ba5072e4727247a04462782
pkgname = bfg-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 046933bd43b5..dbcf5316e18e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=bfg-git
_gitname=bfg-repo-cleaner
pkgver=r465.aeee9e3
pkgrel=1
-pkgdesc='Removes large blobs like git-filter-branch does, but faster. Git version, no politics.'
+pkgdesc='Removes large blobs like git-filter-branch does, but faster.'
url='https://github.com/rtyley/bfg-repo-cleaner'
arch=('any')
license=('GPL3')
@@ -12,22 +12,15 @@ depends=('java-runtime>8' 'bash')
makedepends=('sbt')
conficts=('bfg')
source=("git+https://github.com/rtyley/bfg-repo-cleaner.git"
- "bfg.sh"
- "clean.patch")
+ "bfg.sh")
sha256sums=('SKIP'
- 'a41ad8ff48364c1118e69f5c1c6c5c070d56ad1d2f9cd09bca3c095385a6b530'
- '99088f640a8ae89521eb5c5bfbdd96be348b1ccd6ba5072e4727247a04462782')
+ 'a41ad8ff48364c1118e69f5c1c6c5c070d56ad1d2f9cd09bca3c095385a6b530')
pkgver() {
cd "$_gitname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$_gitname"
- patch --forward --strip=2 --input="${srcdir}/clean.patch"
-}
-
build() {
cd "$_gitname"
sbt "bfg/assembly"
diff --git a/clean.patch b/clean.patch
deleted file mode 100644
index 624fed42239a..000000000000
--- a/clean.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff --unified --recursive --text --color src/bfg-repo-cleaner/bfg/src/main/scala/com/madgag/git/bfg/cli/Main.scala src-clean/bfg-repo-cleaner/bfg/src/main/scala/com/madgag/git/bfg/cli/Main.scala
---- src/bfg-repo-cleaner/bfg/src/main/scala/com/madgag/git/bfg/cli/Main.scala 2020-03-07 22:47:53.614049094 +0100
-+++ src-clean/bfg-repo-cleaner/bfg/src/main/scala/com/madgag/git/bfg/cli/Main.scala 2020-03-07 23:09:14.514918941 +0100
-@@ -23,7 +23,6 @@
- import com.madgag.git._
- import com.madgag.git.bfg.GitUtil._
- import com.madgag.git.bfg.cleaner._
--import com.madgag.git.bfg.cli.stoptrump.dontGiveUp
-
- object Main extends App {
-
-@@ -59,11 +58,9 @@
-
- RepoRewriter.rewrite(repo, config.objectIdCleanerConfig)
- repo.close()
--
-- println(dontGiveUp())
- }
- }
- }
- }
-
--}
-\ No newline at end of file
-+}