summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2021-05-08 09:01:08 +0000
committerAntonio Rojas2021-05-08 09:01:08 +0000
commit757f9b9790b7011ee491a36b40ad1d6fa344101b (patch)
tree298bad3e25615cae36746ea449365dd679d5099b
downloadaur-757f9b9790b7011ee491a36b40ad1d6fa344101b.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD45
-rw-r--r--remove-dangerous-rpath.patch21
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0c6f8bbe746
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = bfgminer
+ pkgdesc = Bitcoin miner featuring overclocking, monitoring, fan speed control and remote management. For FPGA/GPU/CPU Bitcoin mining.
+ pkgver = 5.5.0
+ pkgrel = 3
+ url = https://bitcointalk.org/?topic=877081
+ arch = x86_64
+ license = GPL3
+ makedepends = uthash
+ makedepends = yasm
+ depends = curl
+ depends = jansson
+ depends = libevent
+ depends = libmicrohttpd
+ depends = libusb
+ depends = lm_sensors
+ optdepends = opencl-nvidia: OpenCL implementation for NVIDIA
+ source = https://luke.dashjr.org/programs/bitcoin/files/bfgminer/5.5.0/bfgminer-5.5.0.txz
+ source = remove-dangerous-rpath.patch
+ sha512sums = d1adae473e01fcf1cd0efde74d3e8ce10609e520397d688bf4e226c1113c1606c782e3cfdba6847f1a3886cac30de6b5baa03b731aca86287d53bf01ef705cdb
+ sha512sums = 087aa60d818ff37cb7a4edce7a34331a492b5e379a8e034d7a2e02b106bb6ea52b4ce6a1077f602987a2c30213bc185063990796a828ae95f60cff03c7a0bc3f
+
+pkgname = bfgminer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff64bb5ce358
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Christian Rebischke <chris.rebischke@archlinux.org>
+# Contributor: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=bfgminer
+pkgver=5.5.0
+pkgrel=3
+pkgdesc="Bitcoin miner featuring overclocking, monitoring, fan speed control and remote management. For FPGA/GPU/CPU Bitcoin mining."
+arch=('x86_64')
+depends=('curl' 'jansson' 'libevent' 'libmicrohttpd' 'libusb' 'lm_sensors')
+makedepends=('uthash' 'yasm')
+optdepends=('opencl-nvidia: OpenCL implementation for NVIDIA')
+url='https://bitcointalk.org/?topic=877081'
+license=('GPL3')
+source=("https://luke.dashjr.org/programs/bitcoin/files/${pkgname}/${pkgver}/${pkgname}-${pkgver}.txz"
+ 'remove-dangerous-rpath.patch')
+sha512sums=('d1adae473e01fcf1cd0efde74d3e8ce10609e520397d688bf4e226c1113c1606c782e3cfdba6847f1a3886cac30de6b5baa03b731aca86287d53bf01ef705cdb'
+ '087aa60d818ff37cb7a4edce7a34331a492b5e379a8e034d7a2e02b106bb6ea52b4ce6a1077f602987a2c30213bc185063990796a828ae95f60cff03c7a0bc3f')
+
+prepare() {
+ cd "${pkgname}"-"${pkgver}"
+
+ patch -p1 -i "${srcdir}"/remove-dangerous-rpath.patch
+}
+
+build() {
+ cd "${pkgname}"-"${pkgver}"
+
+ ./configure --prefix=/usr \
+ --sbindir=/usr/bin \
+ --enable-cpumining \
+ --enable-bfsb \
+ --enable-metabank \
+ --enable-scrypt \
+ --enable-opencl \
+ --with-udevrulesdir=/usr/lib/udev/rules.d
+ # --enable-knc (FS#33640)
+ make
+}
+
+package() {
+ cd "${pkgname}"-"${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/remove-dangerous-rpath.patch b/remove-dangerous-rpath.patch
new file mode 100644
index 000000000000..897aca50598c
--- /dev/null
+++ b/remove-dangerous-rpath.patch
@@ -0,0 +1,21 @@
+diff -Naur bfgminer-4.8.0-orig/configure bfgminer-4.8.0/configure
+--- bfgminer-4.8.0-orig/configure 2014-10-04 20:54:28.717071865 -0400
++++ bfgminer-4.8.0/configure 2014-10-04 20:55:50.140274445 -0400
+@@ -14111,7 +14111,7 @@
+ ac_abs_srcdir=$ac_abs_top_srcdir$ac_dir_suffix
+
+ libbase58_CFLAGS='-I'"${ac_abs_top_srcdir}"'/libbase58'
+- libbase58_LIBS='-L'"${ac_abs_top_builddir}"'/libbase58/.libs -Wl,-rpath,\$$ORIGIN/libbase58/.libs'"$origin_LDFLAGS"' -lbase58'
++ libbase58_LIBS='-L'"${ac_abs_top_builddir}"'/libbase58/.libs -Wl,-rpath,/usr/lib'"$origin_LDFLAGS"' -lbase58'
+ libbase58_SUBDIRS=libbase58
+ libbase58_EXTRADEPS=libbase58_directory
+ BUNDLED_LIB_RULES="$BUNDLED_LIB_RULES
+@@ -14380,7 +14380,7 @@
+ ac_abs_srcdir=$ac_abs_top_srcdir$ac_dir_suffix
+
+ libblkmaker_CFLAGS='-I'"${ac_abs_top_srcdir}"'/libblkmaker'
+- libblkmaker_LIBS='-L'"${ac_abs_top_builddir}"'/libblkmaker/.libs -Wl,-rpath,\$$ORIGIN/libblkmaker/.libs'"$origin_LDFLAGS"' -lblkmaker_jansson-0.1 -lblkmaker-0.1'
++ libblkmaker_LIBS='-L'"${ac_abs_top_builddir}"'/libblkmaker/.libs -Wl,-rpath,/usr/lib'"$origin_LDFLAGS"' -lblkmaker_jansson-0.1 -lblkmaker-0.1'
+ libblkmaker_SUBDIRS=libblkmaker
+ libblkmaker_EXTRADEPS=libblkmaker_directory
+ BUNDLED_LIB_RULES="$BUNDLED_LIB_RULES