summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordarkbarker2019-04-17 18:14:17 +0500
committerdarkbarker2019-04-17 18:17:08 +0500
commitacc104be8765d859fda36f9ef41140e4c392ff2a (patch)
tree10cad5a68dafed07ef66bca4cbd158c12cf2791f
parent470ce863f79e5137dafb367788fd37470aa5ab86 (diff)
downloadaur-acc104be8765d859fda36f9ef41140e4c392ff2a.tar.gz
update, numerable fix
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6575a5fb6652..d78e8127016d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Jan 10 13:02:29 UTC 2019
+# Wed Apr 17 13:16:49 UTC 2019
pkgbase = bgbillingclient72
pkgdesc = Client runner for billing system BGBilling 7.2
- pkgver = 7.2.1901091804
+ pkgver = 7.2.1903251819
pkgrel = 2
url = http://bgbilling.ru
install = bgbillingclient.install
diff --git a/PKGBUILD b/PKGBUILD
index ae366a62f04b..ee489685a202 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Dmitry Barker Medvedev <dimon@bitel.ru>
pkgname=bgbillingclient72
-pkgver=7.2.1901091804
+pkgver=7.2.1903251819
pkgrel=2
pkgdesc='Client runner for billing system BGBilling 7.2'
arch=('i686' 'x86_64')
@@ -41,19 +41,24 @@ _rename_var_file() {
}
pkgver() {
- wget --no-remove-listing ftp://ftp.bgbilling.ru/pub/bgbilling/${_vermajor}/${_achivename}_${_vermajor}_*.zip
+ wget --no-remove-listing ftp://ftp.bgbilling.ru/pub/bgbilling/${_vermajor}/${_achivename}_*.zip
# lrwxrwxrwx 1 0 0 34 Jan 09 18:48 BGBillingRunner_7.2.zip -> BGBillingRunner_7.2_1901091804.zip
# -rw-rw-r-- 1 0 0 81124 Jan 09 18:04 BGBillingRunner_7.2_1901091804.zip
- _ver=$(grep -o -P --max-count=1 "${_achivename}_(\d+)\.(\d+)_(\d+)" .listing)
+ # _ver=$(grep -o -P --max-count=1 "${_achivename}_(\d+)\.(\d+)_(\d+)" .listing)
+ # потом стало: BGBillingRunner_1903251819.zip
+ _ver=$(grep -o -P --max-count=1 "${_achivename}_(\d+)" .listing)
# BGBillingRunner_7.2_1901091804
- _v1=$(echo ${_ver}|cut -d'_' -f2)
- _v2=$(echo ${_ver}|cut -d'_' -f3)
- echo "${_v1}.${_v2}"
+ # _v1=$(echo ${_ver}|cut -d'_' -f2) # 7.2
+ # _v2=$(echo ${_ver}|cut -d'_' -f3) # 1901091804
+ # echo "${_v1}.${_v2}"
+ # потом стало: BGBillingRunner_1901091804
+ _v2=$(echo ${_ver}|cut -d'_' -f2) # 1901091804
+ echo "${_vermajor}.${_v2}"
}
package() {
msg2 "unzip distributive"
- unzip -o ./${_achivename}_${_vermajor}_${_verbuild}.zip
+ unzip -o ./${_achivename}_${_verbuild}.zip
msg2 "create structure"
mkdir $pkgdir/opt