summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMr. Outis2018-08-09 21:47:54 -0500
committerMr. Outis2018-08-09 21:59:57 -0500
commit84edecc035a330767e1d00933baae23120314e4d (patch)
treee4ece37fb2d51d6521417df87a0566ff517b103a
downloadaur-84edecc035a330767e1d00933baae23120314e4d.tar.gz
Initial upload: bgc 1.0.0-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20081de18595
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = bgc
+ pkgdesc = Set your background to a color, using X11
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/mroutis/bgc
+ arch = any
+ license = Unlicense
+ depends = xorg-server
+ source = bgc-1.0.0.tar.gz::https://github.com/mroutis/bgc/archive/v1.0.0.tar.gz
+ sha256sums = 1bd9fa8e221f635d76bd8c3382117af8b8c4e1eb74b0921844ce7273cf193612
+
+pkgname = bgc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..218505f7f74f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mr. Outis <mroutis@protonmail.com>
+pkgname=bgc
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Set your background to a color, using X11"
+arch=('any')
+url="https://github.com/mroutis/bgc"
+license=('Unlicense')
+depends=('xorg-server')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('1bd9fa8e221f635d76bd8c3382117af8b8c4e1eb74b0921844ce7273cf193612')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ mkdir -p "${pkgdir}/usr/bin"
+ DESTDIR="${pkgdir}/usr/bin" make install
+}