summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandr Boiko2015-06-16 09:30:08 +1000
committerAlexandr Boiko2015-06-16 09:30:08 +1000
commitb4aa3fd30e4e962f6cdbdf10a064661ad852b9a8 (patch)
treeb39ea7d9eb904f1075945e43f64bd5a741beda06
downloadaur-b4aa3fd30e4e962f6cdbdf10a064661ad852b9a8.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD47
-rw-r--r--bginetaccess.service13
-rw-r--r--setenv.sh.patch13
4 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8288ca18189c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = bginetaccess
+ pkgdesc = Access server for BGBilling
+ pkgver = 6.1.23
+ pkgrel = 1
+ url = http://bgbilling.ru
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = unzip
+ makedepends = dos2unix
+ depends = bgbilling
+ source = ftp://bgbilling.ru/pub/bgbilling/6.1/data/BGInetAccess_6.1_23.zip
+ source = bginetaccess.service
+ source = setenv.sh.patch
+ md5sums = f2bae56657087a2e1e431465e7d96a04
+ md5sums = acb8868e7ee91338d3395cc536e2a52a
+ md5sums = dae4f113fa23e562270e1d935a2a3a12
+
+pkgname = bginetaccess
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71e7f21a067e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Aleksandr Boiko <brdcom@ya.ru>
+pkgname=bginetaccess
+_basename=bgbilling
+_pkgname=BGInetAccess
+_major=6.1
+_minor=23
+pkgver=$_major.$_minor
+pkgrel=1
+pkgdesc="Access server for BGBilling"
+arch=('i686' 'x86_64')
+url="http://bgbilling.ru"
+license=('custom')
+depends=('bgbilling')
+makedepends=('unzip' 'dos2unix')
+source=("ftp://bgbilling.ru/pub/${_basename}/${_major}/data/${_pkgname}_${_major}_${_minor}.zip"
+ 'bginetaccess.service'
+ 'setenv.sh.patch')
+
+package() {
+ install -d -m0755 ${pkgdir}/opt
+ mv ./${_pkgname} ${pkgdir}/opt/${pkgname}
+
+ install -D -m 644 $pkgname.service "$pkgdir/usr/lib/systemd/system/$pkgname.service"
+
+# putting the appropriate access rights to the startup scripts
+ cd ${pkgdir}/opt/${pkgname}
+ chmod 0744 *.sh
+
+# patch
+ patch -p0 <"${srcdir}/setenv.sh.patch"
+
+# converting files to Unix format
+ dos2unix *.sh
+
+# remove win files
+ rm -rf *.ini
+ rm -rf *.bat
+ rm -rf *.exe
+
+# remove junk files
+ rm -rf ./script
+}
+
+# vim:set ts=2 sw=2 ft=sh et:
+md5sums=('f2bae56657087a2e1e431465e7d96a04'
+ 'acb8868e7ee91338d3395cc536e2a52a'
+ 'dae4f113fa23e562270e1d935a2a3a12')
diff --git a/bginetaccess.service b/bginetaccess.service
new file mode 100644
index 000000000000..65e34e5c5ed6
--- /dev/null
+++ b/bginetaccess.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Access server for BGBilling
+Requires=activemq.service
+After=activemq.service
+
+[Service]
+EnvironmentFile=/etc/conf.d/bgbilling
+Type=forking
+ExecStart=/opt/bginetaccess/access_start.sh
+ExecStop=/opt/bginetaccess/access_stop.sh
+
+[Install]
+WantedBy=multi-user.target
diff --git a/setenv.sh.patch b/setenv.sh.patch
new file mode 100644
index 000000000000..feceb8e5640e
--- /dev/null
+++ b/setenv.sh.patch
@@ -0,0 +1,13 @@
+--- setenv.sh.orig 2013-07-30 20:09:05.478278831 +1200
++++ setenv.sh 2013-07-30 20:09:59.274654058 +1200
+@@ -1,7 +1,7 @@
+-JAVA_HOME=
++JAVA_HOME="$JAVA_HOME"
+
+ if [ -z "$JAVA_HOME" ]; then
+ echo "The JAVA_HOME environment variable is not defined"
+ echo "This environment variable is needed to run this program"
+ exit 1
+-fi
+\ No newline at end of file
++fi