summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyechou2018-02-12 12:03:11 -0600
committerkyechou2018-02-12 12:06:02 -0600
commit1a453b8edd7a1f810601b9c3b8402fda5f75ac78 (patch)
tree89f008cc858d97c067782c9832d282d15f9d0d96
downloadaur-1a453b8edd7a1f810601b9c3b8402fda5f75ac78.tar.gz
Initial bgpdump release 1.5.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84e6e5c59334
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = bgpdump
+ pkgdesc = A C library designed to help with analyzing dump files produced by Zebra/Quagga or MRT
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = https://bitbucket.org/ripencc/bgpdump
+ arch = x86_64
+ license = GPL
+ makedepends = autoconf
+ depends = zlib
+ depends = bzip2
+ provides = bgpdump
+ source = https://bitbucket.org/ripencc/bgpdump/get/1.5.0.tar.gz
+ sha512sums = 70cb68eb70fc0a2d10597421c79bca5506f8d089ceffbe7a1c4555ffd871fd0bd5ba1b441c8af94e3a257db56afb5ea20546dcaa4349046187daadd1681febb4
+
+pkgname = bgpdump
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..908433c8b281
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Kuan-Yen Chou <forendef2846 at gmail dot com>
+
+pkgname=bgpdump
+pkgver=1.5.0
+pkgrel=1
+pkgdesc='A C library designed to help with analyzing dump files produced by Zebra/Quagga or MRT'
+depends=('zlib' 'bzip2')
+makedepends=('autoconf')
+arch=('x86_64')
+url="https://bitbucket.org/ripencc/bgpdump"
+license=('GPL')
+provides=('bgpdump')
+source=("https://bitbucket.org/ripencc/bgpdump/get/${pkgver}.tar.gz")
+sha512sums=('70cb68eb70fc0a2d10597421c79bca5506f8d089ceffbe7a1c4555ffd871fd0bd5ba1b441c8af94e3a257db56afb5ea20546dcaa4349046187daadd1681febb4')
+
+build() {
+ cd "$srcdir"/ripencc-bgpdump-*
+ autoheader
+ autoconf
+ ./configure \
+ --prefix="$pkgdir"/usr \
+ --sbindir="$pkgdir"/usr/bin
+ make
+}
+
+package() {
+ cd "$srcdir"/ripencc-bgpdump-*
+ make install
+ install -Dm 644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: set ts=4 sw=4 et :