summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Weiman2018-12-05 11:42:04 -0500
committerMark Weiman2018-12-05 11:42:04 -0500
commit0c2a272c4799ee93cea29e337641dbf37885bb3d (patch)
tree4f347310286a56ee6a731ea5a13ffc9170178538
downloadaur-0c2a272c4799ee93cea29e337641dbf37885bb3d.tar.gz
initial
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5e381cd58ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = bgpstream
+ pkgdesc = An open-source software framework for live and historical BGP data analysis, supporting scientific research, operational monitoring, and post-event analysis
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://bgpstream.caida.org
+ arch = x86_64
+ license = GPL
+ depends = libwandio>=1.0.3
+ optdepends = sqlite3: sqlite data interface
+ source = http://bgpstream.caida.org/bundles/caidabgpstreamwebhomepage/dists/bgpstream-1.2.1.tar.gz
+ md5sums = 18af3b09ef915a3f4465188b9c41e588
+
+pkgname = bgpstream
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9de474cc4d64
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Mark Weiman <mark.weiman@markzz.com>
+
+pkgname=bgpstream
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="An open-source software framework for live and historical BGP data analysis, supporting scientific research, operational monitoring, and post-event analysis"
+arch=('x86_64')
+url="https://bgpstream.caida.org"
+license=('GPL')
+depends=("libwandio>=1.0.3")
+optdepends=("sqlite3: sqlite data interface")
+source=("http://bgpstream.caida.org/bundles/caidabgpstreamwebhomepage/dists/${pkgname}-${pkgver}.tar.gz")
+md5sums=('18af3b09ef915a3f4465188b9c41e588')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --with-sqlite
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}