summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2019-11-09 19:27:32 +0300
committerAnton Leontiev2019-11-09 19:27:32 +0300
commite3737d62670751b5b3d87131514f6b3eeb8dec9e (patch)
treea4067e6718c7c1f086834bd7f1beddeb51cc00e0
parent44d9f4ca0dbdcf7230d2bda5f05eff614821a15a (diff)
downloadaur-e3737d62670751b5b3d87131514f6b3eeb8dec9e.tar.gz
Update to v1.0
Package is switched to another fork: https://github.com/rsharo/bgrep.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD32
2 files changed, 28 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10306d4d8327..347a3f00bb1d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = bgrep
pkgdesc = Binary grep
- pkgver = 0.2
+ pkgver = 1.0
pkgrel = 1
- url = https://github.com/tmbinc/bgrep
+ url = https://github.com/rsharo/bgrep
arch = i686
arch = x86_64
+ arch = armv7h
license = BSD
- source = https://github.com/tmbinc/bgrep/archive/bgrep-0.2.tar.gz
- md5sums = 99846d0a782bd72665349fd0269eaf11
+ checkdepends = vim
+ depends = glibc
+ source = https://github.com/rsharo/bgrep/archive/bgrep-1.0.tar.gz
+ md5sums = 1d69eb383eea5c6b3e6e5532a0fba37f
pkgname = bgrep
diff --git a/PKGBUILD b/PKGBUILD
index 96567ba51334..9477e972d5cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,34 @@
-# Maintainer: Anton Leontiev <bunder /at/ t-25.ru>
+# Maintainer: Anton Leontiev <scileont /at/ gmail.com>
+
pkgname=bgrep
-pkgver=0.2
+pkgver=1.0
pkgrel=1
pkgdesc='Binary grep'
-arch=('i686' 'x86_64')
-url='https://github.com/tmbinc/bgrep'
+arch=('i686' 'x86_64' 'armv7h')
+url='https://github.com/rsharo/bgrep'
license=('BSD')
-source=(https://github.com/tmbinc/bgrep/archive/$pkgname-$pkgver.tar.gz)
-md5sums=('99846d0a782bd72665349fd0269eaf11')
+depends=('glibc')
+checkdepends=('vim')
+source=(https://github.com/rsharo/bgrep/archive/$pkgname-$pkgver.tar.gz)
+md5sums=('1d69eb383eea5c6b3e6e5532a0fba37f')
+
+prepare() {
+ cd $pkgname-$pkgname-$pkgver
+ ./bootstrap
+}
build() {
- cd "$srcdir/$pkgname-$pkgname-$pkgver"
+ cd $pkgname-$pkgname-$pkgver
+ ./configure --prefix=/usr
make
}
check() {
- cd "$srcdir/$pkgname-$pkgname-$pkgver/test"
- ./bgrep-test.sh
+ cd $pkgname-$pkgname-$pkgver
+ make check
}
package() {
- install -Dm755 "$srcdir/$pkgname-$pkgname-$pkgver/bgrep" "$pkgdir/usr/bin/bgrep"
-} \ No newline at end of file
+ cd $pkgname-$pkgname-$pkgver
+ make install DESTDIR="$pkgdir"
+}