summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancois Truphemus (melchips)2015-07-06 22:30:52 +0200
committerFrancois Truphemus (melchips)2015-07-06 22:30:52 +0200
commitdb3c6f70990ee1168729366b21687987be8e48c6 (patch)
tree52d8203ba7d0c923610d602cb32a44436648c5a0
downloadaur-db3c6f70990ee1168729366b21687987be8e48c6.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6afa9826330f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = bgs-git
+ pkgdesc = simple background setter based on imlib2
+ pkgver = 0.6.r2.gd455737
+ pkgrel = 2
+ url = https://github.com/Gottox/bgs
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = MIT
+ makedepends = git
+ makedepends = libunistring
+ depends = imlib2
+ depends = libxinerama
+ provides = bgs
+ conflicts = bgs
+ source = bgs::git+https://github.com/Gottox/bgs.git
+ sha256sums = SKIP
+
+pkgname = bgs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c56f26cb6f70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: melchips <truphemus dot francois at gmail dot com>
+# Contributor: Lari Tikkanen <lartza@wippies.com>
+pkgname=bgs-git
+pkgver=0.6.r2.gd455737
+pkgrel=2
+pkgdesc="simple background setter based on imlib2"
+arch=('i686' 'x86_64' 'armv7h')
+url="https://github.com/Gottox/bgs"
+license=('MIT')
+depends=('imlib2' 'libxinerama')
+makedepends=('git' 'libunistring')
+source=(bgs::git+https://github.com/Gottox/bgs.git)
+provides=("bgs")
+conflicts=("bgs")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/bgs"
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$srcdir/bgs"
+ # add the correct settings to config.mk
+ sed -e "s|^\(\s*PREFIX =\).*|\1 /usr|" -i config.mk
+ make
+}
+
+package() {
+ cd "$srcdir/bgs"
+ make DESTDIR=$pkgdir install
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}