summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-09-15 09:14:42 -0600
committerMark Wagie2023-09-15 09:14:42 -0600
commit223187e838863c0785fc85ba52c1cd9e8ed4ee70 (patch)
treeec518ab49dfd1d12e6bd45287043b8ab30f5abe9
parent56605f127372f11c136f56f075f9e3f16f950cf7 (diff)
downloadaur-223187e838863c0785fc85ba52c1cd9e8ed4ee70.tar.gz
2.0.4
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 18 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 069d3ea9840e..28171b733361 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = bibata-cursor-theme
pkgdesc = Material Based Cursor Theme
- pkgver = 2.0.3
+ pkgver = 2.0.4
pkgrel = 1
url = https://github.com/ful1e5/Bibata_Cursor
arch = any
license = GPL3
makedepends = python-clickgen>=2.0.0
options = !strip
- source = bibata-cursor-theme-2.0.3.tar.gz::https://github.com/ful1e5/Bibata_Cursor/archive/v2.0.3.tar.gz
- sha256sums = d3128cc7172d95b226a6e6856d8f0b689b81acc366ac17fe78b6e092f1af482e
+ source = bibata-cursor-theme-2.0.4.tar.gz::https://github.com/ful1e5/Bibata_Cursor/archive/v2.0.4.tar.gz
+ source = bibata-cursor-theme-2.0.4-bitmaps.zip::https://github.com/ful1e5/Bibata_Cursor/releases/download/v2.0.4/bitmaps.zip
+ sha256sums = 88ee477d6e4a0be93ac0a5df6c5340a0643278c6b0e0ca8efc8c91c0de8e4f58
+ sha256sums = c6f2e56e4d65fd4f009f70f564346410ba18985d9c03fbc55a0f0ee558dbc1c4
pkgname = bibata-cursor-theme
diff --git a/PKGBUILD b/PKGBUILD
index 9b3e48a91e89..a8fc16d6193b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: ful1e5 <kaizmandhu at gmail dot com>
pkgname=bibata-cursor-theme
-pkgver=2.0.3
+pkgver=2.0.4
pkgrel=1
pkgdesc="Material Based Cursor Theme"
arch=('any')
@@ -11,16 +11,20 @@ url="https://github.com/ful1e5/Bibata_Cursor"
license=('GPL3')
makedepends=('python-clickgen>=2.0.0')
options=('!strip')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('d3128cc7172d95b226a6e6856d8f0b689b81acc366ac17fe78b6e092f1af482e')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+ "$pkgname-$pkgver-bitmaps.zip::$url/releases/download/v$pkgver/bitmaps.zip")
+sha256sums=('88ee477d6e4a0be93ac0a5df6c5340a0643278c6b0e0ca8efc8c91c0de8e4f58'
+ 'c6f2e56e4d65fd4f009f70f564346410ba18985d9c03fbc55a0f0ee558dbc1c4')
prepare() {
- cd Bibata_Cursor-$pkgver
+ mv -f bitmaps "Bibata_Cursor-$pkgver"
+
+ cd "Bibata_Cursor-$pkgver"
rm -rf themes
}
build() {
- cd Bibata_Cursor-$pkgver
+ cd "Bibata_Cursor-$pkgver"
declare -A names
names["Bibata-Modern-Amber"]="Yellowish and rounded edge Bibata cursors."
@@ -31,7 +35,7 @@ build() {
names["Bibata-Original-Ice"]="White and sharp edge Bibata cursors."
for key in "${!names[@]}"; do
- comment="${names[$key]}";
+ comment="${names[$key]}"
ctgen build.toml -p x11 -d "bitmaps/$key" -n "$key" -c "$comment" &
PID=$!
wait $PID
@@ -39,7 +43,7 @@ build() {
}
package() {
- cd Bibata_Cursor-$pkgver
- install -d "$pkgdir"/usr/share/icons
- cp -r themes/Bibata-* "$pkgdir"/usr/share/icons/
+ cd "Bibata_Cursor-$pkgver"
+ install -d "$pkgdir/usr/share/icons"
+ cp -r themes/Bibata-* "$pkgdir/usr/share/icons/"
}