summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorExcitable Snowball2018-06-02 05:05:37 -0700
committerExcitable Snowball2018-06-02 05:05:37 -0700
commitc5b929cd1134c949b00e1cc5219264de84cdf704 (patch)
tree3d9cb5cf8a1a912bd1c998f49e89fe68513ac14c
downloadaur-c5b929cd1134c949b00e1cc5219264de84cdf704.tar.gz
0.3.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD18
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0947321673f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = bibcure
+ pkgdesc = Helps you to have a better bibtex file
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/bibcure/bibcure
+ arch = any
+ license = AGPL3
+ depends = python-bibtexparser
+ depends = python-future
+ depends = doi2bib
+ depends = title2bib
+ depends = arxivcheck
+ source = bibcure-0.3.0.tar.gz::https://github.com/bibcure/bibcure/archive/0.3.0.tar.gz
+ sha256sums = b87a89ea2c1f7b414c41aba9f382da14cc2dfeb2a5b8c92e04625c745080bd81
+
+pkgname = bibcure
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7699d983fd4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Excitable Snowball <excitablesnowball@gmail.com>
+
+pkgname=bibcure
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Helps you to have a better bibtex file"
+url="https://github.com/bibcure/bibcure"
+arch=('any')
+license=('AGPL3')
+depends=('python-bibtexparser' 'python-future' 'doi2bib' 'title2bib' 'arxivcheck')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/bibcure/bibcure/archive/$pkgver.tar.gz")
+sha256sums=('b87a89ea2c1f7b414c41aba9f382da14cc2dfeb2a5b8c92e04625c745080bd81')
+
+package() {
+ cd $pkgname-$pkgver
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}