summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Bocken2020-11-07 13:19:36 +0100
committerAlexander Bocken2020-11-07 13:19:36 +0100
commit5581abb13899f510ebd4e31e8def44c50fb27213 (patch)
treefd68dc4ba0f16fe8d7bd4f6d3789ccc4b7b32d3f
downloadaur-5581abb13899f510ebd4e31e8def44c50fb27213.tar.gz
inital release to AUR
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8154e979d434
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = bibel-git
+ pkgdesc = Read the the German Catholic Einheitsübersetzung, with annotations, from your terminal
+ pkgver = r46.061947a
+ pkgrel = 1
+ url = https://github.com/AlexBocken/bibel
+ arch = any
+ license = custom:Public Domain
+ depends = bash
+ source = bibel::git+https://github.com/AlexBocken/bibel.git
+ md5sums = SKIP
+
+pkgname = bibel-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0999b4b9dd34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alexander Bocken <alexander@bocken.org>
+pkgname=bibel-git
+pkgver=r46.061947a
+pkgrel=1
+pkgdesc="Read the the German Catholic Einheitsübersetzung, with annotations, from your terminal"
+arch=(any)
+depends=(bash)
+url="https://github.com/AlexBocken/bibel"
+license=('custom:Public Domain')
+source=('bibel::git+https://github.com/AlexBocken/bibel.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm755 bibel $pkgdir/usr/bin/bibel
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/${pkgname}/LICENSE
+}