summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Clark2020-12-26 13:29:08 +0000
committerPaul Clark2020-12-26 13:29:08 +0000
commite0608e64ddcaa4aae5133997259cc6d71ca04ac4 (patch)
treeb929005413c3d470fd66baba8bb7b0e025a2f0ab
parente531e840fd5d681dc6832c79d7bcefd03df5bf25 (diff)
downloadaur-e0608e64ddcaa4aae5133997259cc6d71ca04ac4.tar.gz
Version 4.31
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
-rw-r--r--makefile.patch10
3 files changed, 19 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c574de201f9..f6c6d024d052 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = bible-kjv
pkgdesc = King James Bible, Concordance, and Command-Line Viewer
- pkgver = 4.30
+ pkgver = 4.31
pkgrel = 1
url = http://www.debian.org/
- arch = i686
arch = x86_64
license = GPL
makedepends = perl
- depends = glibc
- source = http://ftp.debian.org/debian/pool/main/b/bible-kjv/bible-kjv_4.30.tar.gz
+ depends = readline
+ source = http://ftp.debian.org/debian/pool/main/b/bible-kjv/bible-kjv_4.31.tar.gz
source = makefile.patch
- md5sums = 0fd7710b7d5c60543756701474cc9d01
- md5sums = e234e246b418fbd75a3855e321775a9e
+ sha256sums = 80a325d01b7e42a36b8c3673ca96a4373fc3280e9fa96cb7ca5e5c24bca0c3ac
+ sha256sums = 91bb9de66b17d67b72f5de57098928aa897ba62a77b5ddcf2695e74c0a97d572
pkgname = bible-kjv
diff --git a/PKGBUILD b/PKGBUILD
index 6d12d42e5e04..26425e127268 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,28 @@
# Maintainer: Paul Clark <paul500clark at gmail dot com>
# Contributor: David Koenig <koenigdmj@gmail.com>
pkgname=bible-kjv
-pkgver=4.30
+pkgver=4.31
pkgrel=1
pkgdesc="King James Bible, Concordance, and Command-Line Viewer"
-arch=(i686 x86_64)
+arch=(x86_64)
url="http://www.debian.org/"
license=('GPL')
-depends=('glibc')
+depends=('readline')
makedepends=('perl')
source=(http://ftp.debian.org/debian/pool/main/b/${pkgname}/${pkgname}_${pkgver}.tar.gz
makefile.patch)
-md5sums=('0fd7710b7d5c60543756701474cc9d01'
- 'e234e246b418fbd75a3855e321775a9e')
+sha256sums=('80a325d01b7e42a36b8c3673ca96a4373fc3280e9fa96cb7ca5e5c24bca0c3ac'
+ '91bb9de66b17d67b72f5de57098928aa897ba62a77b5ddcf2695e74c0a97d572')
package () {
patch -p1 < makefile.patch
- cd $pkgname
+ cd work
+
+ export MAKEFLAGS="-j1"
# upstream ebuild wants "make all", not just "make"
- make DEST="/usr" DESTLIB="/usr/share/$pkgname" MAKEFLAGS="-j1" all || return 1
+ make DEST="/usr" DESTLIB="/usr/share/$pkgname" all || return 1
make DEST="$pkgdir/usr" DESTLIB="$pkgdir/usr/share/$pkgname" install
# copy for user convenience
diff --git a/makefile.patch b/makefile.patch
index d65c25dffab4..b2520b5af667 100644
--- a/makefile.patch
+++ b/makefile.patch
@@ -1,13 +1,13 @@
diff -aur src0/bible-kjv/Makefile src1/bible-kjv/Makefile
---- src0/bible-kjv/Makefile 2011-06-25 13:20:00.000000000 +0100
-+++ src1/bible-kjv/Makefile 2018-05-03 16:30:18.151493296 +0100
-@@ -88,7 +88,7 @@
+--- src0/work/Makefile 2011-06-25 13:20:00.000000000 +0100
++++ src1/work/Makefile 2018-05-03 16:30:18.151493296 +0100
+@@ -88,7 +88,6 @@
# I use environment variables for these...
#CFLAGS = -g
-CFLAGS = -Wall -Wformat -Werror -Wshadow -W -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wcast-align -Wcast-qual -Wbad-function-cast -Wpointer-arith -g2 -ggdb -DDESTLIB=\"$(DESTLIB)\"
-+CFLAGS = -O2 -DDESTLIB=\"$(DESTLIB)\"
- LDFLAGS =
+-LDFLAGS =
++CFLAGS += -DDESTLIB=\"$(DESTLIB)\"
LDADD = -lreadline
@@ -442,23 +442,17 @@