summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-08 20:27:01 +0200
committerStefan Husmann2015-06-08 20:27:01 +0200
commit9e1fa449d39720c8ce5579e43d7b2b3b864d4275 (patch)
tree4e60e14455ca9ef6026d5057c09fa80d83a22acb
downloadaur-9e1fa449d39720c8ce5579e43d7b2b3b864d4275.tar.gz
initial version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b5235746d4d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = biblesync
+ pkgdesc = multicast shared co-navigation library for Bible programs
+ pkgver = 1.1.2
+ pkgrel = 2
+ url = http://sourceforge.net/projects/gnomesword/files/BibleSync/1.1.2/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = libutil-linux
+ depends = gcc-libs
+ source = http://downloads.sourceforge.net/project/gnomesword/BibleSync/1.1.2/biblesync-1.1.2.tar.gz
+ md5sums = 25bc063de3da2fc087954c746714f735
+
+pkgname = biblesync
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5369a912210f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+pkgname=biblesync
+pkgver=1.1.2
+pkgrel=2
+pkgdesc="multicast shared co-navigation library for Bible programs"
+url="http://sourceforge.net/projects/gnomesword/files/BibleSync/1.1.2/"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('libutil-linux' 'gcc-libs')
+makedepends=('cmake')
+source=("http://downloads.sourceforge.net/project/gnomesword/BibleSync/$pkgver/$pkgname-$pkgver.tar.gz")
+md5sums=('25bc063de3da2fc087954c746714f735')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ [[ -d build ]] || mkdir -p build
+ cd build
+ cmake -DBUILD_SHARED_LIBS=TRUE -DCMAKE_INSTALL_PREFIX=/usr -DLIBDIR=/usr/lib ..
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver/build
+ make DESTDIR=$pkgdir install
+}