summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-03-14 18:19:07 +0300
committerCaleb Maclennan2020-03-14 18:19:07 +0300
commit91b08b9da8863d8e808b269607590f751069b282 (patch)
tree1f0acdf2eed17f2e208c71c9d07ffb55f49e6a69
parent74ef6a9e3da9ce9dd12bd035493558e9434f6505 (diff)
downloadaur-91b08b9da8863d8e808b269607590f751069b282.tar.gz
Wrap long code lines, organize code
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6cf1fc8d7034..ac4e0e8ee591 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,10 +20,12 @@ pkgver() {
git describe --tags --abbrev=7 HEAD | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
- cd "${pkgname%-git}"
+prepare() {
mkdir -p build
- cd build
+}
+
+build() {
+ cd "${pkgname%-git}/build"
cmake \
-DBUILD_SHARED_LIBS=TRUE \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -33,9 +35,11 @@ build() {
}
package() {
- cd "${pkgname%-git}"
- install -Dm644 -t "$pkgdir/usr/share/licences/$pkgname/" AUTHORS COPYING LICENSE
- install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname/" ChangeLog README.md man/specification.txt WIRESHARK
- cd build
+ cd "${pkgname%-git}/build"
make DESTDIR="$pkgdir/" install
+ pushd ..
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname/" \
+ ChangeLog README.md man/specification.txt WIRESHARK
+ install -Dm644 -t "$pkgdir/usr/share/licences/$pkgname/" \
+ AUTHORS COPYING LICENSE
}