summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-03-20 22:08:16 +0100
committerhaawda2018-03-20 22:08:16 +0100
commit40cef5b1e2b00278d01ae16ac3a2715158fbb789 (patch)
tree8113571fd26ff05edef04d11e744e8bed73315bd
parenta2a41c312de42522d470a9117ee06c281b69e32a (diff)
downloadaur-40cef5b1e2b00278d01ae16ac3a2715158fbb789.tar.gz
pull from github
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD21
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 935b69a2c6ad..b8c40cabe68f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = bibstuff
pkgdesc = Collection of python2 scripts and modules for interacting with BibTeX style databases of citation references
- pkgver = 1.3.1
- pkgrel = 2
+ pkgver = 1.3.102
+ pkgrel = 1
url = http://dschwilk.github.io/bibstuff
arch = any
license = MIT
+ makedepends = git
depends = python2-simpleparse
- source = bibstuff.zip::https://github.com/dschwilk/bibstuff/archive/master.zip
- md5sums = 4d89e8356f99456adae34aeede5af79b
+ source = git+https://github.com/dschwilk/bibstuff#commit=17036096234206f32531747e326af2ca57b48d38
+ md5sums = SKIP
pkgname = bibstuff
diff --git a/PKGBUILD b/PKGBUILD
index 9a20db9278a9..0323bee93407 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,33 @@
# Contributor: Gour <gour@gour-nitai.com>
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=bibstuff
-pkgver=1.3.1
-pkgrel=2
+pkgver=1.3.102
+pkgrel=1
pkgdesc="Collection of python2 scripts and modules for interacting with BibTeX style databases of citation references"
url="http://dschwilk.github.io/bibstuff"
arch=('any')
license=('MIT')
depends=('python2-simpleparse')
-source=(bibstuff.zip::https://github.com/dschwilk/bibstuff/archive/master.zip)
-md5sums=('4d89e8356f99456adae34aeede5af79b')
+makedepends=('git')
+source=(git+https://github.com/dschwilk/bibstuff#commit=17036096234206f32531747e326af2ca57b48d38)
+md5sums=('SKIP')
prepare() {
- cd $srcdir/$pkgname-master
+ cd $pkgname
find . -name "*.py" -exec sed -i '1s+python+python2+' {} \;
}
package() {
- cd $srcdir/$pkgname-master
+ cd $pkgname
python2 setup.py install --root=$pkgdir
# copying license information
- install -D -m644 license.txt $pkgdir/usr/share/licenses/$pkgname/license.txt
+ install -D -m644 license.txt "$pkgdir"/usr/share/licenses/$pkgname/license.txt
# copying readme information
- install -Dm644 README.rst $pkgdir/usr/share/doc/$pkgname/README.rst
+ install -Dm644 README.rst "$pkgdir"/usr/share/doc/$pkgname/README.rst
# copying examples directory
- install -d $pkgdir/usr/share/doc/$pkgname/examples
- cp examples/* $pkgdir/usr/share/doc/$pkgname/examples
+ install -d "$pkgdir"/usr/share/doc/$pkgname/examples
+ cp examples/* "$pkgdir"/usr/share/doc/$pkgname/examples
}