summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-08 20:27:15 +0200
committerStefan Husmann2015-06-08 20:27:15 +0200
commitbe2c12feb616423be593f1c0daf6fdc23ecbad07 (patch)
tree23f7cfe47c554fb946b13b93b5d06f16da366165
downloadaur-be2c12feb616423be593f1c0daf6fdc23ecbad07.tar.gz
initial version
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD33
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad49d94b8431
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = bibstuff
+ pkgdesc = Collection of python2 scripts and modules for interacting with BibTeX style databases of citation references
+ pkgver = 1.0.0
+ pkgrel = 3
+ url = http://code.google.com/p/bibstuff/
+ arch = any
+ license = MIT
+ depends = python2-simpleparse
+ source = http://bibstuff.googlecode.com/files/bibstuff-1.0.0.tar.gz
+ md5sums = 02dfd248f265e30fc70641f65c2d0208
+
+pkgname = bibstuff
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c577095e49fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: Gour <gour@gour-nitai.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+pkgname=bibstuff
+pkgver=1.0.0
+pkgrel=3
+pkgdesc="Collection of python2 scripts and modules for interacting with BibTeX style databases of citation references"
+url="http://code.google.com/p/bibstuff/"
+arch=('any')
+license=('MIT')
+depends=('python2-simpleparse')
+source=(http://$pkgname.googlecode.com/files/$pkgname-$pkgver.tar.gz)
+md5sums=('02dfd248f265e30fc70641f65c2d0208')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ python2 setup.py install --root=$pkgdir
+
+ # copying license information
+ install -D -m644 license.txt $pkgdir/usr/share/licenses/$pkgname/license.txt
+
+ # copying readme information
+ install -Dm644 README.txt $pkgdir/usr/share/doc/$pkgname/README.txt
+
+ # copying examples directory
+ install -d $pkgdir/usr/share/doc/$pkgname/examples
+ cp examples/* $pkgdir/usr/share/doc/$pkgname/examples
+ for _i in $pkgdir/usr/lib/python2.7/site-packages/bibgrammar.py \
+ $pkgdir/usr/share/doc/bibstuff/examples/jmaker.py \
+ $pkgdir/usr/lib/python2.7/site-packages/bibname.py
+ do
+ sed -i '1s+python+python2+' $_i
+ done
+}