summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-07-10 12:12:12 +0200
committerStefan Husmann2015-07-10 12:12:12 +0200
commitd5e88fcb95f057f367497e2f83c91bc8eeaa1c7f (patch)
tree6d3ca041560d38d5bf1bd736af17b2d720f0a339
parent6d98a61faa3c017b06c92f37aa0e9acafc2f8dd5 (diff)
downloadaur-d5e88fcb95f057f367497e2f83c91bc8eeaa1c7f.tar.gz
Update
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD21
2 files changed, 13 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed1784fc7afa..a3cdd7167089 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = bibstuff
pkgdesc = Collection of python2 scripts and modules for interacting with BibTeX style databases of citation references
- pkgver = 1.0.0
- pkgrel = 4
- url = http://code.google.com/p/bibstuff/
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = http://dschwilk.github.io/bibstuff
arch = any
license = MIT
depends = python2
- source = http://bibstuff.googlecode.com/files/bibstuff-1.0.0.tar.gz
- md5sums = 02dfd248f265e30fc70641f65c2d0208
+ source = bibstuff.zip::https://github.com/dschwilk/bibstuff/archive/master.zip
+ md5sums = 4d89e8356f99456adae34aeede5af79b
pkgname = bibstuff
diff --git a/PKGBUILD b/PKGBUILD
index f5bff827a921..1fe3f97c2f24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,28 @@
# Contributor: Gour <gour@gour-nitai.com>
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=bibstuff
-pkgver=1.0.0
-pkgrel=4
+pkgver=1.3.1
+pkgrel=1
pkgdesc="Collection of python2 scripts and modules for interacting with BibTeX style databases of citation references"
-url="http://code.google.com/p/bibstuff/"
+url="http://dschwilk.github.io/bibstuff"
arch=('any')
license=('MIT')
depends=('python2')
-source=(http://$pkgname.googlecode.com/files/$pkgname-$pkgver.tar.gz)
-md5sums=('02dfd248f265e30fc70641f65c2d0208')
+source=(bibstuff.zip::https://github.com/dschwilk/bibstuff/archive/master.zip)
+md5sums=('4d89e8356f99456adae34aeede5af79b')
package() {
- cd $srcdir/$pkgname-$pkgver
+ cd $srcdir/$pkgname-master
python2 setup.py install --root=$pkgdir
# copying license information
install -D -m644 license.txt $pkgdir/usr/share/licenses/$pkgname/license.txt
# copying readme information
- install -Dm644 README.txt $pkgdir/usr/share/doc/$pkgname/README.txt
+ install -Dm644 README.rst $pkgdir/usr/share/doc/$pkgname/README.rst
# copying examples directory
install -d $pkgdir/usr/share/doc/$pkgname/examples
cp examples/* $pkgdir/usr/share/doc/$pkgname/examples
- for _i in $pkgdir/usr/lib/python2.7/site-packages/bibgrammar.py \
- $pkgdir/usr/share/doc/bibstuff/examples/jmaker.py \
- $pkgdir/usr/lib/python2.7/site-packages/bibname.py
- do
- sed -i '1s+python+python2+' $_i
- done
+ sed -i '1s+python+python2+' $pkgdir/usr/share/doc/bibstuff/examples/jmaker.py
}