summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-03-20 22:14:31 +0100
committerhaawda2018-03-20 22:14:31 +0100
commit5039e514bf72449903ac2c5e46a0485a6dd45749 (patch)
tree02d2552717d5259a732f91ca86fc1a5dc335379f
parentd63788d2c383620c20fa297cdf61afef77b76b0f (diff)
downloadaur-5039e514bf72449903ac2c5e46a0485a6dd45749.tar.gz
pull from github
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84f8d3c07a20..b964e24a313e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = bibtex2html
pkgdesc = Collection of tools for producing HTML documents from bibtex-bibliographies
- pkgver = 1.98
+ pkgver = 1.98.413
pkgrel = 1
url = http://www.lri.fr/~filliatr/bibtex2html/
arch = i686
arch = x86_64
license = GPL2
makedepends = ocaml
+ makedepends = git
makedepends = hevea
makedepends = texlive-latexextra
makedepends = texlive-bibtexextra
depends = perl
- source = http://www.lri.fr/~filliatr/ftp/bibtex2html/bibtex2html-1.98.tar.gz
- md5sums = 33a96d32d6ca870163855573253aa720
+ source = git+https://github.com/backtracking/bibtex2html.git#commit=8f25afb95a839c9f9522a34013d5c905af14378b
+ md5sums = SKIP
pkgname = bibtex2html
diff --git a/PKGBUILD b/PKGBUILD
index 0ee769b53254..35f6603955f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=bibtex2html
-pkgver=1.98
+pkgver=1.98.413
pkgrel=1
pkgdesc="Collection of tools for producing HTML documents from bibtex-bibliographies"
url="http://www.lri.fr/~filliatr/bibtex2html/"
license=('GPL2')
arch=('i686' 'x86_64')
depends=('perl')
-makedepends=('ocaml' 'hevea' 'texlive-latexextra' 'texlive-bibtexextra')
-source=(http://www.lri.fr/~filliatr/ftp/$pkgname/$pkgname-$pkgver.tar.gz)
-md5sums=('33a96d32d6ca870163855573253aa720')
+makedepends=('ocaml' 'git' 'hevea' 'texlive-latexextra' 'texlive-bibtexextra')
+source=(git+https://github.com/backtracking/bibtex2html.git#commit=8f25afb95a839c9f9522a34013d5c905af14378b)
+md5sums=('SKIP')
build() {
- cd $srcdir/$pkgname-$pkgver
+ cd $pkgname
autoreconf
./configure --prefix=/usr
sed -i 's+-lstr+/usr/lib/ocaml/libcamlstr.a+' Makefile
@@ -24,8 +24,8 @@ build() {
pdflatex manual.tex
}
package() {
- cd $srcdir/$pkgname-$pkgver
- make prefix=$pkgdir/usr install
- install -Dm644 manual.pdf $pkgdir/usr/share/doc/$pkgname/$pkgname.pdf
- install -Dm644 manual.html $pkgdir/usr/share/doc/$pkgname/$pkgname.html
+ cd $pkgname
+ make prefix="$pkgdir"/usr install
+ install -Dm644 manual.pdf "$pkgdir"/usr/share/doc/$pkgname/$pkgname.pdf
+ install -Dm644 manual.html "$pkgdir"/usr/share/doc/$pkgname/$pkgname.html
}