summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2020-09-17 16:51:18 +0200
committerhaawda2020-09-17 16:51:18 +0200
commitea28a334bc4c47a4a98799686a66f1c150de5a47 (patch)
tree43dbcd0eb7f4ee1b534959a2557ca40106a0de1f
downloadaur-ea28a334bc4c47a4a98799686a66f1c150de5a47.tar.gz
initial upload
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af52ee366817
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = bibtex2html-git
+ pkgdesc = Collection of tools for producing HTML documents from bibtex-bibliographies
+ pkgver = 1.99.16.gf1b6b57
+ pkgrel = 1
+ url = https://github.com/backtracking/bibtex2html
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = ocaml
+ makedepends = git
+ makedepends = hevea
+ makedepends = texlive-latexextra
+ makedepends = texlive-bibtexextra
+ depends = perl
+ source = git+https://github.com/backtracking/bibtex2html.git
+ md5sums = SKIP
+
+pkgname = bibtex2html-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9cb4dc0c3e1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Contributor: shade
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=bibtex2html-git
+pkgver=1.99.16.gf1b6b57
+pkgrel=1
+pkgdesc="Collection of tools for producing HTML documents from bibtex-bibliographies"
+url="https://github.com/backtracking/bibtex2html"
+license=('GPL2')
+arch=('i686' 'x86_64')
+depends=('perl')
+makedepends=('ocaml' 'git' 'hevea' 'texlive-latexextra' 'texlive-bibtexextra')
+source=(git+$url.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ git describe --tags | sed 's+-+.+g' | cut -c3-
+}
+
+build() {
+ cd ${pkgname%-git}
+ autoreconf
+ ./configure --prefix=/usr
+ sed -i 's+-lstr+/usr/lib/ocaml/libcamlstr.a+' Makefile
+ make
+ # to get cross references right
+ hevea manual.tex
+ pdflatex manual.tex
+}
+
+package() {
+ cd ${pkgname%-git}
+ make prefix="$pkgdir"/usr install
+ install -Dm644 manual.pdf "$pkgdir"/usr/share/doc/$pkgname/manual.pdf
+ install -Dm644 manual.html "$pkgdir"/usr/share/doc/$pkgname/manual.html
+}