summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaurice Zhou2021-03-15 20:46:48 +0800
committerMaurice Zhou2021-03-15 20:46:48 +0800
commit63585c0a2483021110e921eace21d3100290c750 (patch)
treebc2c2902fc99a5f198b4403ee05236ae0ca04210
parentcef3f06e314876a4eedb5aa1c38e82b4ae88900a (diff)
downloadaur-63585c0a2483021110e921eace21d3100290c750.tar.gz
Update to 0.1.0
Signed-off-by: Maurice Zhou <ja@apvc.uk>
-rw-r--r--.SRCINFO17
-rw-r--r--0000-10_linux-detect-archlinux-initramfs.patch45
-rw-r--r--0000-42_bieaz-detect-archlinux-initramfs.patch13
-rw-r--r--PKGBUILD16
4 files changed, 64 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c445b3382226..501d3b3dbd96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,21 @@
pkgbase = bieaz
- pkgdesc = Shell script ZFS boot environment manager
- pkgver = 0.0.33
+ pkgdesc = boot environment manager for ZFS
+ pkgver = 0.1.0
pkgrel = 1
url = https://gitlab.com/m_zhou/bieaz
arch = any
license = GPL
depends = coreutils
+ depends = awk
+ depends = sed
+ depends = grep
+ depends = zfs-utils
+ depends = sh
optdepends = grub: select boot environment at boot
- source = https://gitlab.com/m_zhou/bieaz/-/archive/0.0.33/bieaz-0.0.33.tar.gz
- source = 0000-42_bieaz-detect-archlinux-initramfs.patch
- md5sums = 2b6f9728094645bd9cac9d6483ab2eb5
- md5sums = 1e6b0557de8f46c8a0db45895821abe5
+ source = https://gitlab.com/m_zhou/bieaz/-/archive/0.1.0/bieaz-0.1.0.tar.gz
+ source = 0000-10_linux-detect-archlinux-initramfs.patch
+ md5sums = 40eac1f815a8a16e3364d53bf9217e6e
+ md5sums = ef173ee9b642c5f51b1b5a3e3138f1c5
pkgname = bieaz
diff --git a/0000-10_linux-detect-archlinux-initramfs.patch b/0000-10_linux-detect-archlinux-initramfs.patch
new file mode 100644
index 000000000000..f045d4b63865
--- /dev/null
+++ b/0000-10_linux-detect-archlinux-initramfs.patch
@@ -0,0 +1,45 @@
+diff --git a/10_linux b/10_linux
+index 9f2e423..10b10b7 100644
+--- a/10_linux
++++ b/10_linux
+@@ -98,6 +98,8 @@ linux_entry ()
+ case $type in
+ recovery)
+ title="$(gettext_printf "%s, with Linux %s (recovery mode)" "${os}" "${version}")" ;;
++ fallback)
++ title="$(gettext_printf "%s, with Linux %s (fallback initramfs)" "${os}" "${version}")" ;;
+ *)
+ title="$(gettext_printf "%s, with Linux %s" "${os}" "${version}")" ;;
+ esac
+@@ -203,7 +205,7 @@ while [ "x$list" != "x" ] ; do
+ basename=`basename $linux`
+ dirname=`dirname $linux`
+ # rel_dirname=`make_system_path_relative_to_its_root $dirname`
+- version=`echo $basename | sed -e "s,^[^0-9]*-,,g"`
++ version=`echo $basename | sed -e "s,vmlinuz-,,g"`
+ alt_version=`echo $version | sed -e "s,\.old$,,g"`
+ linux_root_device_thisversion="${LINUX_ROOT_DEVICE}"
+
+@@ -274,10 +276,21 @@ while [ "x$list" != "x" ] ; do
+ # GRUB_DISABLE_SUBMENU="true"
+ # fi
+
+- if [ "x$is_top_level" = xtrue ] && [ "x${GRUB_DISABLE_SUBMENU}" != xtrue ]; then
++ if [ "x$is_top_level" = xtrue ] && [ "x${GRUB_DISABLE_SUBMENU}" != xy ]; then
+ linux_entry "${OS}" "${version}" simple \
+ "${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_LINUX_DEFAULT}"
+
++ if test -e "${dirname}/initramfs-${version}-fallback.img" ; then
++ initrd="initramfs-${version}-fallback.img"
++
++ if test -n "${initrd}" ; then
++ gettext_printf "Found fallback initrd image(s) in %s:%s\n" "${dirname}" "${initrd_extra} ${initrd}" >&2
++ fi
++
++ linux_entry "${OS}" "${version}" fallback \
++ "${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_LINUX_DEFAULT}"
++ fi
++
+ submenu_indentation="$grub_tab"
+
+ if [ -z "$boot_device_id" ]; then
diff --git a/0000-42_bieaz-detect-archlinux-initramfs.patch b/0000-42_bieaz-detect-archlinux-initramfs.patch
deleted file mode 100644
index 4f0c527a97e3..000000000000
--- a/0000-42_bieaz-detect-archlinux-initramfs.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/10_linux b/10_linux
-index f6b9b39..f95f165 100755
---- a/10_linux
-+++ b/10_linux
-@@ -152,7 +152,7 @@ while [ "x$list" != "x" ] ; do
- gettext_printf "Found linux image: %s\n" "$linux" >&2
- basename=`basename $linux`
- dirname=`dirname $linux`
-- version=`echo $basename | sed -e "s,^[^0-9]*-,,g"`
-+ version=`echo $basename | sed -e "s,vmlinuz-,,g"`
- alt_version=`echo $version | sed -e "s,\.old$,,g"`
- linux_root_device_thisversion="${LINUX_ROOT_DEVICE}"
-
diff --git a/PKGBUILD b/PKGBUILD
index 3ca21adcc15b..85859d20e95b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Maurice Zhou <ja at apvc punkt uk>
pkgname=bieaz
-pkgver=0.0.33
+pkgver=0.1.0
pkgrel=1
-pkgdesc="Shell script ZFS boot environment manager"
+pkgdesc="boot environment manager for ZFS"
arch=(any)
url="https://gitlab.com/m_zhou/bieaz"
license=('GPL')
-depends=('coreutils')
+depends=('coreutils' 'awk' 'sed' 'grep' 'zfs-utils' 'sh')
optdepends=('grub: select boot environment at boot')
source=(
"$url/-/archive/$pkgver/$pkgname-$pkgver.tar.gz"
- "0000-42_bieaz-detect-archlinux-initramfs.patch"
+ "0000-10_linux-detect-archlinux-initramfs.patch"
)
package() {
cd "$pkgname-$pkgver"
@@ -19,8 +19,8 @@ package() {
}
prepare() {
cd "${srcdir}/$pkgname-$pkgver/"
- echo "Patch to detect of Arch Linux initramfs images by grub-mkconfig..."
- patch -Np1 -i "${srcdir}/0000-42_bieaz-detect-archlinux-initramfs.patch"
+ echo "Patch GRUB detection of Arch Linux initramfs/fallback..."
+ patch -Np1 -i "${srcdir}/0000-10_linux-detect-archlinux-initramfs.patch"
}
-md5sums=('2b6f9728094645bd9cac9d6483ab2eb5'
- '1e6b0557de8f46c8a0db45895821abe5')
+md5sums=('40eac1f815a8a16e3364d53bf9217e6e'
+ 'ef173ee9b642c5f51b1b5a3e3138f1c5')