summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaurice Zhou2021-01-02 19:51:55 +0800
committerMaurice Zhou2021-01-02 19:51:55 +0800
commit82f6d970f4eeb615f89d575ad243cd7d13bb7943 (patch)
tree9311b7e39b8aa3febec50cec4e447cec7b95ca0a
downloadaur-82f6d970f4eeb615f89d575ad243cd7d13bb7943.tar.gz
0.0.2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c8c7ee9d6bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = bieaz
+ pkgdesc = Pure shell script Root on ZFS boot environment manager with GRUB integration for Linux
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = https://gitlab.com/m_zhou/bieaz
+ arch = any
+ license = GPL
+ depends = coreutils
+ depends = util-linux
+ depends = zfs
+ optdepends = grub: select boot environment at boot
+ source = https://gitlab.com/m_zhou/bieaz/-/archive/0.0.2/bieaz-0.0.2.tar.gz
+ md5sums = a4b4f1df6f719f357511c9bcbc5eda23
+
+pkgname = bieaz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46b54ed0a278
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Maurice Zhou <ja at apvc punkt uk>
+
+pkgname=bieaz
+pkgver=0.0.2
+pkgrel=1
+pkgdesc="Pure shell script Root on ZFS boot environment manager with GRUB integration for Linux"
+arch=(any)
+url="https://gitlab.com/m_zhou/bieaz"
+license=('GPL')
+depends=('coreutils' 'util-linux' 'zfs')
+optdepends=('grub: select boot environment at boot')
+source=("${url}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+md5sums=('a4b4f1df6f719f357511c9bcbc5eda23')