summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaurice Zhou2021-03-16 12:13:24 +0800
committerMaurice Zhou2021-03-16 12:13:24 +0800
commitad591e56cdc7581c9234a240bf1f6dc235331562 (patch)
treed50564ee52455f3836d44b407fdc50481eff6018
parent15b76056d16f5c87a147a51e6ee9b91417b1ea0c (diff)
downloadaur-ad591e56cdc7581c9234a240bf1f6dc235331562.tar.gz
update
Signed-off-by: Maurice Zhou <ja@apvc.uk>
-rw-r--r--.SRCINFO8
-rw-r--r--0000-10_linux-detect-archlinux-initramfs.patch45
-rw-r--r--PKGBUILD11
3 files changed, 5 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4be1dc90a99..5f0460b198da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bieaz
pkgdesc = boot environment manager for ZFS
- pkgver = 0.1.2
+ pkgver = 0.1.3
pkgrel = 1
url = https://gitlab.com/m_zhou/bieaz
arch = any
@@ -12,10 +12,8 @@ pkgbase = bieaz
depends = zfs-utils
depends = sh
optdepends = grub: select boot environment at boot
- source = https://gitlab.com/m_zhou/bieaz/-/archive/0.1.2/bieaz-0.1.2.tar.gz
- source = 0000-10_linux-detect-archlinux-initramfs.patch
- md5sums = ef85ea278e210d392997ea53f1b5e390
- md5sums = ef173ee9b642c5f51b1b5a3e3138f1c5
+ source = https://gitlab.com/m_zhou/bieaz/-/archive/0.1.3/bieaz-0.1.3.tar.gz
+ md5sums = 2601accb321cd5fb72a1f2e4f9fe0ce5
pkgname = bieaz
diff --git a/0000-10_linux-detect-archlinux-initramfs.patch b/0000-10_linux-detect-archlinux-initramfs.patch
deleted file mode 100644
index f045d4b63865..000000000000
--- a/0000-10_linux-detect-archlinux-initramfs.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff --git a/10_linux b/10_linux
-index 9f2e423..10b10b7 100644
---- a/10_linux
-+++ b/10_linux
-@@ -98,6 +98,8 @@ linux_entry ()
- case $type in
- recovery)
- title="$(gettext_printf "%s, with Linux %s (recovery mode)" "${os}" "${version}")" ;;
-+ fallback)
-+ title="$(gettext_printf "%s, with Linux %s (fallback initramfs)" "${os}" "${version}")" ;;
- *)
- title="$(gettext_printf "%s, with Linux %s" "${os}" "${version}")" ;;
- esac
-@@ -203,7 +205,7 @@ while [ "x$list" != "x" ] ; do
- basename=`basename $linux`
- dirname=`dirname $linux`
- # rel_dirname=`make_system_path_relative_to_its_root $dirname`
-- version=`echo $basename | sed -e "s,^[^0-9]*-,,g"`
-+ version=`echo $basename | sed -e "s,vmlinuz-,,g"`
- alt_version=`echo $version | sed -e "s,\.old$,,g"`
- linux_root_device_thisversion="${LINUX_ROOT_DEVICE}"
-
-@@ -274,10 +276,21 @@ while [ "x$list" != "x" ] ; do
- # GRUB_DISABLE_SUBMENU="true"
- # fi
-
-- if [ "x$is_top_level" = xtrue ] && [ "x${GRUB_DISABLE_SUBMENU}" != xtrue ]; then
-+ if [ "x$is_top_level" = xtrue ] && [ "x${GRUB_DISABLE_SUBMENU}" != xy ]; then
- linux_entry "${OS}" "${version}" simple \
- "${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_LINUX_DEFAULT}"
-
-+ if test -e "${dirname}/initramfs-${version}-fallback.img" ; then
-+ initrd="initramfs-${version}-fallback.img"
-+
-+ if test -n "${initrd}" ; then
-+ gettext_printf "Found fallback initrd image(s) in %s:%s\n" "${dirname}" "${initrd_extra} ${initrd}" >&2
-+ fi
-+
-+ linux_entry "${OS}" "${version}" fallback \
-+ "${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_LINUX_DEFAULT}"
-+ fi
-+
- submenu_indentation="$grub_tab"
-
- if [ -z "$boot_device_id" ]; then
diff --git a/PKGBUILD b/PKGBUILD
index 8afda4953794..ff256adeeb34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maurice Zhou <ja at apvc punkt uk>
pkgname=bieaz
-pkgver=0.1.2
+pkgver=0.1.3
pkgrel=1
pkgdesc="boot environment manager for ZFS"
arch=(any)
@@ -11,16 +11,9 @@ depends=('coreutils' 'awk' 'sed' 'grep' 'zfs-utils' 'sh')
optdepends=('grub: select boot environment at boot')
source=(
"$url/-/archive/$pkgver/$pkgname-$pkgver.tar.gz"
- "0000-10_linux-detect-archlinux-initramfs.patch"
)
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}
-prepare() {
- cd "${srcdir}/$pkgname-$pkgver/"
- echo "Patch GRUB detection of Arch Linux initramfs/fallback..."
- patch -Np1 -i "${srcdir}/0000-10_linux-detect-archlinux-initramfs.patch"
-}
-md5sums=('ef85ea278e210d392997ea53f1b5e390'
- 'ef173ee9b642c5f51b1b5a3e3138f1c5')
+md5sums=('2601accb321cd5fb72a1f2e4f9fe0ce5')