summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDesmond Kabus2020-07-10 17:35:12 +0200
committerDesmond Kabus2020-07-10 17:35:12 +0200
commit7290b9309a10bbe6e50124acaaf56723a80fcb42 (patch)
tree238fbdf744adbc0ebb76d4747daf56725c96bbdf
downloadaur-7290b9309a10bbe6e50124acaaf56723a80fcb42.tar.gz
Add PKGBUILD
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD25
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..74c29241e586
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = bigjubel-git
+ pkgdesc = command line utility to calculate current jubilees
+ pkgver = 10.1.1.r1.gfc89a2f
+ pkgrel = 1
+ url = https://www.kabus.eu/git/bigjubel
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL
+ makedepends = git
+ makedepends = make
+ makedepends = gcc
+ provides = bigjubel
+ conflicts = bigjubel
+ source = bigjubel-git::git://www.kabus.eu/git/bigjubel
+ md5sums = SKIP
+
+pkgname = bigjubel-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..264dabc13c5b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Desmond Kabus <desmond.kabus@protonmail.com>
+
+pkgname=bigjubel-git
+pkgver=10.1.1.r1.gfc89a2f
+pkgrel=1
+pkgdesc="command line utility to calculate current jubilees"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://www.kabus.eu/git/bigjubel"
+license=('GPL')
+depends=()
+makedepends=('git' 'make' 'gcc')
+provides=('bigjubel')
+conflicts=('bigjubel')
+source=('bigjubel-git::git://www.kabus.eu/git/bigjubel')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/${pkgname}"
+ make DESTDIR="$pkgdir/" install
+}