summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2017-12-26 17:31:30 +0200
committerDet2017-12-26 17:31:30 +0200
commit4dc71255a94b5d94b84cb60630fe2836a8865bc8 (patch)
treee756f0d90d008982468cb7413f1e898243dd276f
downloadaur-4dc71255a94b5d94b84cb60630fe2836a8865bc8.tar.gz
Initial upload
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD56
-rw-r--r--biglybt.install23
3 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..04611b08f8aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = biglybt
+ pkgdesc = Feature-filled Bittorrent client based on the Azureus project
+ pkgver = 1.2.0.0
+ pkgrel = 1
+ url = https://www.biglybt.com/
+ install = biglybt.install
+ arch = x86_64
+ license = GPL3
+ makedepends = java-runtime=8
+ depends = desktop-file-utils
+ depends = java-runtime>=8
+ options = !strip
+ source = https://github.com/BiglySoftware/BiglyBT/releases/download/v1.2.0.0/GitHub_BiglyBT_Installer.sh
+ md5sums = a6f5f9297a9dfdcfdc80d22fe8e2c776
+
+pkgname = biglybt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b94a046ad9c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Det <nimetonmaili gmail a-dot com>
+
+pkgname=biglybt
+pkgver=1.2.0.0
+pkgrel=1
+pkgdesc="Feature-filled Bittorrent client based on the Azureus project"
+arch=('x86_64')
+url="https://www.biglybt.com/"
+license=('GPL3')
+depends=('desktop-file-utils' 'java-runtime>=8')
+makedepends=('java-runtime=8')
+options=('!strip')
+install=$pkgname.install
+source=("https://github.com/BiglySoftware/BiglyBT/releases/download/v$pkgver/GitHub_BiglyBT_Installer.sh")
+md5sums=('a6f5f9297a9dfdcfdc80d22fe8e2c776')
+
+prepare() {
+ rm -rf $pkgname
+
+ msg2 "Extrcting GitHub_BiglyBT_Installer.sh..."
+ sh GitHub_BiglyBT_Installer.sh -q -dir "$pkgdir"/opt/$pkgname
+}
+
+package() {
+ cd "$pkgdir"/opt/$pkgname
+
+ msg2 "Creating directory structure..."
+ install -d "$pkgdir"/usr/bin/
+ install -d "$pkgdir"/usr/share/applications/
+ install -d "$pkgdir"/usr/share/licenses/$pkgname/
+ install -d "$pkgdir"/usr/share/pixmaps/
+
+ msg2 "Moving stuff in place..."
+ # Launchers
+ mv $pkgname "$pkgdir"/usr/bin/$pkgname
+
+ # Icon and desktop
+ mv $pkgname.svg "$pkgdir"/usr/share/pixmaps/
+ mv $pkgname.desktop "$pkgdir"/usr/share/applications/
+
+ # Licenses
+ mv 3rdPartyLicences.txt GPL.txt GPLv3.txt "$pkgdir"/usr/share/licenses/$pkgname/
+
+ msg2 "Removing redundancies..."
+ rm swt/swt-{bsd,ppc64,ppc64le,x86}.jar
+ rm biglybt-lightgray.svg biglybt.png
+ rm installer.log
+ rm {,un}registerBiglyBT uninstall updateBiglyBT
+
+ msg2 "Fixing paths..."
+ sed -i "s|#PROGRAM_DIR=.*|PROGRAM_DIR=\"/opt/$pkgname\"|" "$pkgdir"/usr/bin/$pkgname
+ sed -e "s|Exec=.*|Exec=$pkgname %U|" -e "s|Icon=.*|Icon=$pkgname|" \
+ -i "$pkgdir"/usr/share/applications/$pkgname.desktop
+}
+
+
diff --git a/biglybt.install b/biglybt.install
new file mode 100644
index 000000000000..1da5e9d14776
--- /dev/null
+++ b/biglybt.install
@@ -0,0 +1,23 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}${yellow}==>${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+post_install() {
+ note "It is recommended to disable the builtin automatic updater in:
+ Tools > Options > Interface > Start, and
+ Tools > Options > Plugins > Plugin Update"
+}
+
+post_upgrade() {
+ post_install
+}