summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2018-02-03 17:54:49 +0200
committerDet2018-02-03 17:54:49 +0200
commitc825e2a9bc8a5a2bab8a2fefa0f264762e383431 (patch)
tree0ec18d2168c9a415da02b94f88095a713b9ea4a9
parent7a90852a491ddd7029eed2d7582e444f619febc4 (diff)
downloadaur-c825e2a9bc8a5a2bab8a2fefa0f264762e383431.tar.gz
Installation tweaks
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--biglybt.install4
3 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a76b3c1c1ecd..203e4f132121 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,11 +6,11 @@ pkgbase = biglybt
install = biglybt.install
arch = x86_64
license = GPL3
- makedepends = java-runtime=8
+ makedepends = java-runtime>=8
depends = desktop-file-utils
- depends = java-runtime>=8
+ depends = java-runtime>=9
options = !strip
- source = https://github.com/BiglySoftware/BiglyBT/releases/download/v1.4.0.0/GitHub_BiglyBT_Installer.sh
+ source = GitHub_BiglyBT_Installer_1.4.0.0.sh::https://github.com/BiglySoftware/BiglyBT/releases/download/v1.4.0.0/GitHub_BiglyBT_Installer.sh
md5sums = 1e059362ac473e4a8c386bb5115bffa4
pkgname = biglybt
diff --git a/PKGBUILD b/PKGBUILD
index aa03e77e0bad..6165fc178fc8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,19 +7,19 @@ pkgdesc="Feature-filled Bittorrent client based on the Azureus project"
arch=('x86_64')
url="https://www.biglybt.com/"
license=('GPL3')
-depends=('desktop-file-utils' 'java-runtime>=8')
-makedepends=('java-runtime=8')
+depends=('desktop-file-utils' 'java-runtime>=9')
+makedepends=('java-runtime>=8')
options=('!strip')
install=$pkgname.install
-source=("https://github.com/BiglySoftware/BiglyBT/releases/download/v$pkgver/GitHub_BiglyBT_Installer.sh")
+source=("GitHub_BiglyBT_Installer_$pkgver.sh::https://github.com/BiglySoftware/BiglyBT/releases/download/v$pkgver/GitHub_BiglyBT_Installer.sh")
md5sums=('1e059362ac473e4a8c386bb5115bffa4')
prepare() {
rm -rf $pkgname
- msg2 "Extrcting GitHub_BiglyBT_Installer.sh..."
- export app_java_home=$(echo /usr/lib/jvm/java-8*/jre)
- sh GitHub_BiglyBT_Installer.sh -q -dir "$srcdir"/$pkgname
+ msg2 "Extrcting GitHub_BiglyBT_Installer_$pkgver.sh..."
+ export app_java_home=$(ls -d /usr/lib/jvm/java-{8,9,10}-*/jre | sort -V | tail -1)
+ sh GitHub_BiglyBT_Installer_$pkgver.sh -q -dir "$srcdir"/$pkgname
}
package() {
diff --git a/biglybt.install b/biglybt.install
index 92391a1a1b6d..f6f9782b7917 100644
--- a/biglybt.install
+++ b/biglybt.install
@@ -14,8 +14,8 @@ yellow="${bold}$(tput setaf 3)"
post_install() {
note "It is recommended to disable the builtin automatic updater in:
- Tools > Options > Interface > Start, and
- Tools > Options > Plugins > Plugin Update"
+ Tools > Options > Interface > Start, and
+ Tools > Options > Plugins > Plugin Update"
}
post_upgrade() {