summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormrxx2018-12-06 21:52:42 +0100
committermrxx2018-12-06 21:52:42 +0100
commite198024a80b6de9cb35afdedfe27d0ad313856e1 (patch)
treeef554dde3c01521b0a165a38c2661b2edb30ed75
parentd615a0fb611e94ca4aba94a8bd9f4d3b9f11fdea (diff)
downloadaur-e198024a80b6de9cb35afdedfe27d0ad313856e1.tar.gz
Fix wrong local .desktop file creation by the Java installer
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD21
-rw-r--r--biglybt.install1
3 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30269010b9c7..586eb043bbc4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = biglybt
pkgdesc = Feature-filled Bittorrent client based on the Azureus project
pkgver = 1.7.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.biglybt.com/
install = biglybt.install
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = biglybt
depends = java-runtime>=9
options = !strip
source = GitHub_BiglyBT_Installer_1.7.0.0.sh::https://github.com/BiglySoftware/BiglyBT/releases/download/v1.7.0.0/GitHub_BiglyBT_Installer.sh
- md5sums = 75635369c4272bdc82be062a3cde367e
+ sha256sums = d8024c3620cd1090ac04b5907d05cd4f2667668a4e7ff5af363713f180c3af3f
pkgname = biglybt
diff --git a/PKGBUILD b/PKGBUILD
index c5ab103b9e67..e192f2a1970e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Det <nimetonmaili gmail a-dot com>
+# Maintainer: mrxx <mrxx at cyberhome dot at>
+# Contributor: Det <nimetonmaili gmail a-dot com>
pkgname=biglybt
pkgver=1.7.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Feature-filled Bittorrent client based on the Azureus project"
arch=('x86_64')
url="https://www.biglybt.com/"
@@ -11,7 +12,7 @@ depends=('desktop-file-utils' 'java-runtime>=9')
options=('!strip')
install=$pkgname.install
source=("GitHub_BiglyBT_Installer_$pkgver.sh::https://github.com/BiglySoftware/BiglyBT/releases/download/v$pkgver/GitHub_BiglyBT_Installer.sh")
-md5sums=('75635369c4272bdc82be062a3cde367e')
+sha256sums=('d8024c3620cd1090ac04b5907d05cd4f2667668a4e7ff5af363713f180c3af3f')
package() {
if [[ ! -f /usr/bin/javac ]]; then
@@ -27,6 +28,11 @@ package() {
export app_java_home="/usr/lib/jvm/default"
sh GitHub_BiglyBT_Installer_$pkgver.sh -q -dir "$srcdir"/$pkgname
+ # Remove local .desktop file only if it was just created by the Java installer
+ # (which creates it a) in the wrong place and b) with wrong paths, therefore
+ # preventing the start of the program via the launcher)
+ find ~/.local/share/applications -name $pkgname.desktop -cmin -1 -exec rm {} +
+
cd "$srcdir"/$pkgname
msg2 "Creating directory structure..."
@@ -36,6 +42,10 @@ package() {
install -d "$pkgdir"/usr/share/licenses/$pkgname/
install -d "$pkgdir"/usr/share/pixmaps/
+ msg2 "Fixing paths..."
+ sed -i "s|#PROGRAM_DIR=.*|PROGRAM_DIR=\"/opt/$pkgname\"|" $pkgname
+ sed -i -e "s|Exec=.*|Exec=$pkgname %U|" -e "s|Icon=.*|Icon=$pkgname|" $pkgname.desktop
+
msg2 "Moving stuff in place..."
# Launchers
mv $pkgname "$pkgdir"/usr/bin/
@@ -55,9 +65,4 @@ package() {
msg2 "Installing to /opt..."
mv * "$pkgdir"/opt/$pkgname/
-
- msg2 "Fixing paths..."
- sed -i "s|#PROGRAM_DIR=.*|PROGRAM_DIR=\"/opt/$pkgname\"|" "$pkgdir"/usr/bin/$pkgname
- sed -e "s|Exec=.*|Exec=$pkgname %U|" -e "s|Icon=.*|Icon=$pkgname|" \
- -i "$pkgdir"/usr/share/applications/$pkgname.desktop
}
diff --git a/biglybt.install b/biglybt.install
index 51855e5e952c..f6f9782b7917 100644
--- a/biglybt.install
+++ b/biglybt.install
@@ -20,5 +20,4 @@ post_install() {
post_upgrade() {
post_install
- note "Previous package versions left an invalid .desktop in ~/.local/share/applications/ that has to be manually removed."
}