summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvert Vorster2022-05-20 23:34:21 +0100
committerEvert Vorster2022-05-20 23:34:21 +0100
commit3cf935776842bd615974f32f0b86e9a6904dafdf (patch)
tree7d48e9f7a79b2c5f332edac86cf2c1bfc5ec8c1d
downloadaur-3cf935776842bd615974f32f0b86e9a6904dafdf.tar.gz
initial submission
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD45
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6b999518ea1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = bigsh0t-plugins-git
+ pkgdesc = Plugins like frei0r for dealing with VR (git version)
+ pkgver = 2.5.r12.g8e852fb
+ pkgrel = 1
+ url = https://bitbucket.org/leo_sutic/bigsh0t/src/main/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = opencv
+ depends = git
+ optdepends = opencv
+ provides = bigsh0t-plugins
+ conflicts = bigsh0t-plugins
+ source = git+https://bitbucket.org/leo_sutic/bigsh0t.git
+ sha256sums = SKIP
+
+pkgname = bigsh0t-plugins-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b4bab2e15378
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Evert Vorster < gmail-com: evorster >
+
+pkgname=bigsh0t-plugins-git
+_srcname=bigsh0t
+pkgver=2.5.r12.g8e852fb
+pkgrel=1
+pkgdesc='Plugins like frei0r for dealing with VR (git version)'
+arch=('i686' 'x86_64')
+url=https://bitbucket.org/leo_sutic/bigsh0t/src/main/
+license=('GPL')
+depends=('git')
+makedepends=('git' 'opencv')
+optdepends=('opencv')
+provides=('bigsh0t-plugins')
+conflicts=('bigsh0t-plugins')
+source=('git+https://bitbucket.org/leo_sutic/bigsh0t.git')
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$_srcname"
+ mkdir -p Release-Linux
+}
+
+pkgver() {
+ cd "$_srcname"
+ printf '%s' "$(git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//')"
+}
+
+build() {
+ cd "$_srcname"
+ cd Release-Linux
+ cmake -S .. -B . -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/lib/frei0r-1
+ mkdir -p "$pkgdir"/share/shotcut/qml/filters/
+ cd "$builddir"
+ cd "$_srcname"
+ cp -rp Release-Linux/bigsh0t-2.6-linux/lib/frei0r-1/* $pkgdir/usr/lib/frei0r-1/
+ cp -rp Release-Linux/bigsh0t-2.6-linux/shotcut/share/shotcut/qml/filters/* $pkgdir/share/shotcut/qml/filters/
+# cp -rp Release-Linux/bigsh0t-$(echo $pkgver | cut -s -d"." -f1,2)-linux/lib/frei0r-1/* $pkgdir/usr/lib/frei0r-1/
+# cp -rp Release-Linux/bigsh0t-$(echo $pkgver | cut -s -d"." -f1,2)-linux/shotcut/share/shotcut/qml/filters/* $pkgdir/share/shotcut/qml/filters/
+}