summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoremma2023-03-22 01:07:24 -0400
committeremma2023-03-22 01:07:24 -0400
commit0102657d25748e42cdaeb235f2cf17ed657c9e73 (patch)
treee320f4ba740560f9c361fd8c7c74ecbc474df6da
downloadaur-0102657d25748e42cdaeb235f2cf17ed657c9e73.tar.gz
initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b6040d2395ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = bike
+ pkgdesc = Tool that prints “bike” to the standard output.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://git.tebibyte.media/emma/bike
+ arch = any
+ license = CC0
+ provides = bike
+ source = https://git.tebibyte.media/emma/bike/archive/1.0.0.tar.gz
+ sha256sums = SKIP
+
+pkgname = bike
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb8ef8bbd795
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Emma Tebibyte <emma@tebibyte.media>
+
+pkgname="bike"
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Tool that prints “bike” to the standard output."
+arch=("any")
+url="https://git.tebibyte.media/emma/bike"
+license=("CC0")
+source=("https://git.tebibyte.media/emma/bike/archive/1.0.0.tar.gz")
+provides=("bike")
+
+sha256sums=("SKIP")
+
+build() {
+ cd "$srcdir/bike"
+ "$CC" -o bike bike.c
+}
+
+package() {
+ cd "$srcdir/bike"
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/man/man1"
+ cp bike "$pkgdir/usr/bin"
+ cp bike.1 "$pkgdir/usr/share/man/man1"
+}