summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOriginCode2018-02-01 22:31:36 +0800
committerOriginCode2018-02-01 22:31:36 +0800
commit70df827aaf291780931919c0c203b3880a5173a4 (patch)
tree28e9ba5c8eb3e32c775c49a1bc61fb2c05c8de23
parent1bec1d59787e1e6fd0bee6db664def26bf906b1f (diff)
downloadaur-70df827aaf291780931919c0c203b3880a5173a4.tar.gz
Changed the way to fetch the source, improved the script.
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d4578a81d473..47baa13b8fbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,13 +9,16 @@ install=${pkgname}.install
license=('MIT')
depends=('cairo' 'libxtst' 'libxi' 'gtk2' 'libxrandr' 'pango' 'fontconfig' 'libxss' 'gdk-pixbuf2' 'nss' 'freetype2' 'nspr' 'gconf' 'libxext' 'libxdamage' 'atk' 'libxrender' 'libxcomposite' 'libxcursor' 'libxfixes' 'libx11' 'alsa-lib' 'libcups')
makedepends=('tar' 'git')
+source=('git+https://github.com/OriginCode/AURFiles')
+md5sums=('SKIP')
+
build() {
- git clone https://github.com/OriginCode/AURFiles
- cp ./AURFiles/${pkgname}.tar.gz .
+ cd "$srcdir/AURFiles"
tar xvf ./${pkgname}.tar.gz
}
+
package() {
+ cp -r ${srcdir}/AURFiles/${pkgname} .
install -d "${pkgdir}/opt/${pkgname}"
- cp -r bilibili-live-helper/* "${pkgdir}/opt/${pkgname}"
+ cp -r ./bilibili-live-helper/* "${pkgdir}/opt/${pkgname}"
}
-